Under review

Error connecting to device. BusConnectionStatus.Broken

Dieter Kraewinkels 5 years ago in Devices / KNX updated 5 years ago 5

Image 2241

Image 2239

See related : https://support.comfortclick.com/communities/4/topics/1713-error-connecting-to-knx-device?comment_form_activate=true

KNX falcon disconnecting every 3-5 minutes on average. Had the problem before (a few times per 24hrs). Now problem is worse. 

After upgrading to version 4.6.1 I now get a more detailed error message that reads as follow : “Error connecting to device. BusConnectionStatus.Broken”.

I’m on Minix Windows 10, with a Weinzierl BAOS 771.

Image 2242

Under review


thank you for reporting this problem. Can you also try and update to the latest BETA version and test the KNX connection?

Best regards,


Thank you for the quick response.

Meanwhile, believe it or not, the problem actually stopped at 5.30 AM this morning (smartphone screenshot from previous post was taken at 7.14 AM).

Below you can see that the issue ended with a wider(?) connection error (one Sonos speaker got disconnected too). You can also see that the last error message reads "CheckCommunication". After that, it reconnected, and no more errors...

Attached also the Log Devices.txt export (4.47 PM) this afternoon.

I'll monitor this and will try the BETA version suggestion if the issue reappears.



Hi Dieter,

I recommend to go to Beta 4.6.14, much more stable as 4.6.15 (had to roll back). I experience lots of Basic and Http device disconnection with the latest Beta. However, KNX is fine for me.

As a side note: for my configuration (KNX router on my intranet) I had to set "NAT=false" to get my KNX connection stable. 




Just a quick note, as I also had a similar problem:

Please check the production date of your Weinzierl BAOS 771, as it may have a firmware bug.

As stated on one of my previous posts, I had a problem with my BAOS 771. I contacted Weinzierl and they updated my firmware free of charge. I was having slow connections, and some connection drop outs, and after the update everything is working great.


If you have the chance, try your bOS with another KNX/IP interface. But probably your BAOS may have the same problem as mine. You can check the production date on the back of the BAOS, it has 4 digit. Contact Weinzierl and tell them those numbers, so they can find out if it's an old firmware problem.

And as Fabien referred, check the NAT option to false, as you're using a local IP address, and you don't need the Network Address Translation option. I'm using KNX IP connection type instead of KNXnet/IP (Falcon).

Hope it helps.

Best regards

Thank you for the tips. So far, it's still stable (48hrs now). I'll update this post later on.