0
Under review

Very slow reading / writing + timeout errors with WEINZIERL BAOS 771

Ricardo Pinto | visiontech.pt 2 years ago in bOS Server updated 12 months ago 12

Hi,


I've been using a temporary JUNG IPS 100 REG IP interface on bOS, and it was working fine.


But I had to change that temporary IP interface for a BAOS 771 from WEINZIERL.


As you may know, BAOS actually let's you use IP tunneling for programming / visualization, and also to use it as Bus Access Object Server, for prototyping, third party integration etc.


As soon as I started using the BAOS with bOS, I've noticed that bOS is extremely slow reading / writing.


In fact, when the KNX connection becomes true, bOS tries to read every feedback and it shows "No response to read from..." in every address. While this happens, I can see on ETS bOS trying to read the feedbacks almost with a 2 to 3 second delay between them.


If I run a scene for example, it tries to execute the scene at the same very slow speed, 2 to 3 seconds in every group address of the scene.


If using the BAOS on ETS for programming, it works at a "regular" read / write speed.


If using the BAOS with the internal DPT server, it works fast at reading / writing.


If I use it on bOS and click in two or three lights very quick for example, it turns the first one, 2 to 3 seconds and turns the next one, and so one.


I know that BAOS 771 is "old" and with a 10BaseT ethernet connection, but it's a very strange behavior.


Ant tips on that?


Best regards

Under review

Hello Ricardo,


the read timeout setting is set under Timing in KNX nodey you can try playing around with that. bOS will wait (default 3s) for a response, if there is no response in that time, bOS will send response timeout and will send the next command. If the device responds immediately, the next command is send right after the response. Did you also try with connection type KNXnetIPTunneling?


Best regards.

Hi,


I've conducted several tests, but I don't find any conclusion:


Using KNXIP connection type:


The KNX connects, but if I try to use any kind of device in bOS (click a light, a shutter, etc), the connection drops immediately and comes back again a few seconds later (about 30 seconds later). So it's unusable.


But if I don't touch anything, the connection keeps working and keeps getting updates from the bus. So, the connection drops only if the interaction goes bOS > KNX. If the KNX bus updates any group address, the connection is OK and doesn't drop.


Using KNXnetIPTunneling connection type:


The KNX connects, I can click everything, but when clicking in more than one circuit, or running a scene (with several addresses inside), the actuators are executed very slowly, with about 2 to 3 second delay. I tried to change the Read Timeout value but it doesn't change anything.


Also note, that with the previous IP device, I didn't had any problem.


More important, is that this only happens on the direction bOS > KNX. If I use a third party app, or ETS, to update the group addresses, the addresses are updated fast, and bOS receives those updates also fast. So the problem is actually from bOS to KNX.


Best regards

Hello,


its quite strange to see this happening using this BAOS and bOS. I will open a ticket in for our developing team and order one BAOS 771 from WEINZIERL and test it in the office and see what the issue might be. Strange to see that everything works fast in ETS and not in bOS, as it uses the same Falcon driver .dll as the ETS does so the performance should be the same. I will keep you updated on this situation as it develops.


Best regards.

In addition,


which version of ETS are you using when configuring the 771? Also, how old is the module? After some research, it seems that the older 771's had this "slow connection" issue and needed a firmware update in order to make it work normally, not sure if this is the same thing here but there are similarities.


Regards.

Hi,


I own the module for some years now. According to the production numbers stamped on the back, the module is from 2011. The numbers are 1511 (first two production calendar week, last two production year).


I used this module everytime, for programming installations, and recently to use with bOS. Never had any problem so far...


The strange thing is, the slow connection only happens when the origin is bOS. If I use ETS and press read on a certain address several times, it answers, more or less quick. If I use the internal BAOS itself (like with my own HTML+JS prototype), it writes and reads fast.


But if I open bOS and click on several lights for example, very quick, like in a daily usage, the first light turns on, then after 2/3 seconds the second, and so on... it also happens with scenes, etc, so it happens with everything that goes from bOS to KNX. It also happens that when the KNX connection state becomes true, bOS starts to read the feedback status I defined, and it also reads each one with a 2/3 second delay between them (that's when it gets lots of errors saying "No response to read from...".


The opposite (KNX to bOS) is working great. Let's say that I update several setpoints at the same time, press an all off button on the installation etc, bOS gets the feedbacks normally, with no slow connection.


I'm using ETS4. But I've used ETS3 with the BAOS since I bought it.


Haven't found anything about firmware updates, neither any firmware files on their webpage, do you know how to do it?


Best regards

Its quite strange to see this slow connection with bOS as it uses the same connection as ETS, since we never had this issue until now, the best thing would be to get one of those modules and test in the office... New ones can get quite expensive though, will do my best to get hands on one and test it and see what the issue might be, i will be in touch will more details in the next days.


Best regards.

Hi,


Thanks. If it's hard enough to test, it's ok. I'm starting to think that it's a buggy interface or something. But what it bothers me is that while using ETS it works normally. While using the BAOS part it works normally. When getting updates from the bus it works normally. When using bOS to KNX, it works very slow.


More findings:


I have a costumer that has a CI-KNX (basically a Crestron interface to KNX, which is actually a BAOS 771. A plain Weinzierl device with a Crestron stamp on it).


I think that module is more recent than mine, so I gave it a test and used that costumer interface to push his installation into to my bOS.


I can actually use KNXIP (where on mine I can't). It doesn't give any errors when the connection states becomes true.


So, assuming that the device is exactly the same as mine, the only difference is the production year and a stamp, I'm really starting thinking that the problem might me from my module.


Do you know any process of firmware updating? Shall I contact Weinzierl? If I try to explain, and they see that the problem only occurs on bOS > KNX, they will think that the problem is the software and not the module.


If the problem would be from the software, than I wouldn't be able to use also the "BAOSCreston'ish" module, right?


Best regards

Hello,


from what i've read online, you need to ship the module to them and they can update the firmware, strange way of doing it but that's the info i've got.. It would be best if you could contact them and ask regarding the firmware update..


Best regards.

Hi,


I've contacted Weinzierl support, and they do confirm that there's a firmware issue when using newer falcon driver.


They also told me that they can update the firmware, all I need is to send the module to them.


I'll send them the module, and then test it again when I get it back.


Thanks

Best regards

Hello Ricardo,

I was experiencing exactly the same problems. When starting a scene, after 2 seconds the first command was executed and after another 2 seconds the other command and so on!

When reading this I noticed that I also was using the BAOS 771 interface. I changed this interface to an ABB interface and the problem was solved.

There must be something wrong in the Weinzirl interface.

Kind regards,

Yannick

Hi Yannick,

It's a firmware problem on older versions of the BAOS 771.

Contact Weinzierl support, and tell them the numbers on the back of the module. They will ask you to send them the module, and they will update the BAOS free of charge.

Best regards

Just to give you more details, here's the response from Weinzierl when I contacted them:

"There is a firmware issue with older BAOS 771 and newer falcon driver (e.g. ETS5), I guess the bOS is using this driver. There is a firmware upgrade for this, but it only can be done by us. If you want an upgrade, please send the devices to the address written in my e-mail signature. As soon as we receive the devices we will send you an complaint confirmation with delivery date of the upgraded devices."

So that's it, you can contact them, as they're aware of the issue on older BAOS 771.

After the firmware update, the BAOS is running perfectly.

Best regards