Under review

error connecting to KNX device

Francois Lesueur 6 years ago in Devices / KNX updated by Dieter Kraewinkels 5 years ago 27


I'm getting many "error connecting to KNX device".

On my first system (Grinder), this is happening from times to times, for a very short period of time (<1 min). 

This is not impacting the good operation of the system, except if this happening when bOS needs to issue a KNX command, but that's very rare, and then I noticed an impact only once.

I thought that maybe this was linked to my IP network that needed some troubleshooting.

But I've got another system, a KNX Jigsaw, for which the KNX error connecting to device is occurring every 2 minutes ! The KNX interface being incorporated into the Jigsaw, this can't be an issue with my environment. 

I'm not using KNX on this Jigsaw, so I just disables the KNX interface, and problem was fixed for me. 

Still I would like to understand how to fix these "error connecting to device" incidents. 

I'm also getting them from times to times for all IP-connected devices: global Caché, Philips Hue, Denon amplifier, etc... 



Are you usink KNX or not?, if you don't use KNX you must disable KNX device.


I'm not using it on my Jigsaw, so I turned it off. 

I am using it on my Grinder, and I am getting the error connecting to device messages

How do you connect to KNX, by USB or IP? if is IP what sort? Tuneling ,routing ? have you checked that both devices are in the same IP range?


Both Grinder and KNX IP gateway are on the same LAN : Grinder is on, and the gateway is on

I'm having similar issues on my JigSaw. Even got a new device from ComfortClick without it resolving my issue. Did you resolve your issues?

Hello, I didn't have the "wrongAck Sequence" message ; so, I don't think that is the same issue. 

And this isn't happening as often as you ; only once or twice a day

The wrongAck message has started more recently. It doesnt give any more information so I'm not sure what it is.

I'm administrating another building with a JigSaw and it has a more similar issue like yours:

These are the only messages between 17/01 and today. Seems like it's more normal than not? Both are running server v.4.4.4


I'm having similar problems. IP gateways go offline for ~30sec then they come back online. This all happens seemingly on random times and quantities.  Im using mainly Weinzierl 731. But on another object we used Siemens N148/22 and they are acting the same way.

Log for the 731 gateway

Log for the N148/22 

My knx timing settings are default right now. Read timeout is 3000ms and Write Telegrams per Second is 10. Should I change them to slower values? 

So far I haven't noticed any problems with this if they come back online they function just fine, but I contacted our reseller for the gateways and they said they have never had this problem before. All devices are configured to static IPs and all are behind a Mikrotik switch and router and there is no ip conflicts or networks restarts. I've also checked the ETS diagnostic's and found no errors. 

I've got exactly the same issue. I'm not sure this is KNX gateways related because I'm having similar issues on all IP-controlled devices : Hue bridge, Global Caché, Denon amplifier, etc... 

Was using before another smart home box, and I didn't have the problem at all. So I would tend to think this is an issue with the way bOS is communicating with the IP network.

Under review


if you're facing these issues and are both running windows machines, try changing the connection type to KNXnetIPTunneling and try using our Falcon KNX connection type and see if there are any improvements.

Best regards,


I've modified the setup this morning on my Grinder as you suggested. 

So far, so good ; but let's wait a couple of days to confirm. 

Are there similar solutions on Jigsaw ? My second system is a Jigsaw KNX.





This trick worked for my gateways too, so far no disconnects.


5 days without a single error ; that's great. Thank you so much for your help. 

Hello. In last few months I been having Jigsaw KNX issue where KNX cannot connect to KNX bus. In the end I have been forcet to use external IP/KNX device. In last update there was KNX improvments in notes but same problem is occuring. Any solution for this?


there could be some issues with the KNX module on the device, or could be a simple KNX driver update that can be done manually. Please contact me at david.boben@comfortclick.com and we can schedule a remote session and check the KNX connection and resolve this issue.

Best regards.


I am also facing the KNX Connection issue ,

it was working with 4.5.0 version 

but when I updated to latest  i.e 4.5.12 . 

it started giving error of KNX Connection

{ Devices : 7/28/2019 1:41:33 PM : Error : Devices\KNX : Reconnect: OnDataReceived: Index was outside the bounds of the array.}

I tried knx ip/routing FALCON Connection type but no solution


we're already working on fixing the problem with the Index was outside the bounds... error. You should be able to see this resolved with our future updates

Best regards,


I'm also having issues on a previous working installation (Jigsaw). It looks like the server won't receive information from knx.

i've checked the wiring, 29V goes in the jigsaw.

when i push a button on the comfort click it keeps giving no respons, (worked previous fine) until a power failure.

ETS5 won't receive information from the knx.

Jigsaw server version: 4.5.14


@dave, could you email us information for the server so we can check what's happening with the hardware (there could be something wrong with the KNX module on the device). Additional info on how to connect will be provided, please contact us: david.boben@comfortclick.com

@Nasser, did you try deleting the page and adding it back in? Also, what are you displaying on this page?

Best regards,


I noticed that the reconnecting thing is back for one of my building that is running bOS 4.4.4, But with Falcon driver. 

Disconnects for 10sec and reconnects. Strangely 2 smaller buildings that are setup as KNXIP dont do these reconnects, and 1 bigger building that is setup as KNXIpTunneling does not do this.

Log show that this has been going on like this for two months. Not sure what has changed. 

Edit: I was wrong about the bigger building not doing this, I looked again at the logs and it does the same reconnects but not everyday. It did disconnect/reconnect 7 times on 11.10.19 last friday after that there has been no disconnects.


Same type of issues here. The problem went away this summer after moving to KNX IP (Falcon)... but it’s back for a few weeks now.

Tonight, after upgrading to version 4.6.1 I now get a more detailed error message that reads as follow : “Error connecting to device. BusConnectionStatus.Broken”.

Any tips?

Thank you


Also tried to go back to classic “KNX IP” setting, but the. Getting the following errors:

I’m on Windows 10, with a Weinzierl BAOS 771.

I can join the group here, recently updated my bOS to the latest (non-beta) version and KNX (through USB) disconnects and connects again within 0.5 minute around 2 to 3 times per 24h.  Most of the time it's not an issue but from time to time it doesn't send or receives any more KNX messages after this event even though the status is connected again.  Only thing I can do is open bOS Config and disconnect and reconnect KNX manually. I'm running a Wienzierl USB interface on a Minix Windows 10 mini-PC.  It worked fine for about 3 years now so I'm suspecting something changed in the bOS KNX driver ?  I already ran the "Fix USB issue" feature that seems to be new in bOS Config but without succes.  I also made sure the Windows option "allow Windows to turn off this device to safe power" is DISABLED for all USB ports in the Windows Device Manager.  It's really frustrating since it for example doens't turn on my heating system, my curtains, alarm clocks in the morning etc... This needs to be solved or I'll have to find another visualization package which would be a shame since I really like bOS.

I’m also on a Minix. Not sure this is related.