0
Under review

Z-wave Alarm Command Class -not available

Calin Birtocean 3 years ago in Devices / Z-Wave updated by n muthu N Muthu 3 years ago 16

Hi,


I have installed and added to Z-wave node the Carbon Monoxide Detector, ZCOMBO from First Alert.

Based on the manufacturer manual the following command classes are supported:

• BASIC

• BATTERY

• CONFIGURATION

• ASSOCIATION

• ALARM_V1

• MANUFACTURER_SPECIFIC

• VERSION


When integrated in bOS I do not see the Alarm Command Class being available. Here are the parameters that I am looking for to monitor:

Alarm                                    Alarm Type                        Level

Smoke Alarm                    0x01                                      0x00 or 0xFF

CO Alarm                            0x02                                      0x00 or 0xFF

Malfunction Alarm          0x09                                      0x00 or 0xFF

Test Alarm                          0x0C                                      0x00 or 0xFF

Heartbeat Alarm              0x0D                                      0xFF

CO Sensor End of Life    0x0E                                      0x00 or 0xFF



I was assuming to find all the alarms under "Notification" class command, but only the following are available:

The values are not changing when the Test Alarm is active(the test button is pushed).


The Battery value has changed, that's how I know the device is communicating.


The device is Associated to Controller 1.


Could you please advise if the alarms can be monitored in bOS?


Thank you,

Calin


Under review

Hello,


which version of bOS are you using? You could try updating to the latest beta version where additional settings have been updated with our z-wave driver. Sometimes inclusion process doesn't complete correctly, causing some missing commands so try excluding and including the device again, you can also try to delete the device from the list and waking the device again, check if the association groups are set correctly (z-wave controller under lifeline)


Best regards,

Also, did you check if the Basic values change when alarm is triggered?

The server version is 4.4.1, I've tried including and excluding the device several times. 

The device is association to group 1.

When the alarm is triggered the Basic and Notification values are not changing. Only for the battery I have seen a change in value.


Regards,

Calin

Hello,


could you please check Debug log while triggering the alarm so we can see if the device is sending any information.

In your bOS open Logs, select Debug tab and click the Record button, then try triggering the device and see if the device sends any information.


Best regards,

Hello,


Thank you for the tip for using the Debug tab, it is very useful.

When pressing the test/silence button the battery value is the only one received:


When the actual alarm is triggered there is no information received, not even the battery value.

Is there anything that can be checked? Or should I assume that the device is malfunctioning. 


Regards,

Calin  

Hello,


this is quite strange that the bOS does not receive any information regarding the alarm, if this was a newer device with new classes which bOS does not support we could implement them and the device should be working, but since it's an older device, which contains all the classes and options that are implemented in the bOS the device should be working normally. Is there any additional parameters you can set to receive information about the alarm?


Best regards.

I tried everything, but still doesn't work. At this point I am assuming the device is malfunctioning. Trying to order another one soon....

Hello,


I have tested another brand new unit and I am getting the same results. 

When the smoke alarm is triggered the bOS doesn't get updated. The values are not changing when the Test Alarm is activated (the test button is pushed). The only value changing is the Battery value.


Would you please take a look at the controller settings and confirm that this device(ZCOMBO) is supported in bOS.

Here are the debug logs:

2018_03_27_ZCOMBO Exclusion_Log Debug.txt

2018_03_27_ZCOMBO Inclusion_Log Debug.txt

2018_03_28_ZCOMBO Test_Silence Button Pressed_Log Debug.txt

2018_03_28_ZCOMBO Smoke Alarm Triggered_Log Debug.txt


The specification for the class commands supported is here:

Z-wave Smoke_CO detector 83852.docx


The server version is 4.4.1, the controller 1 is associated to group 1 .



Thank you,

Calin


Hello,


thank you for all the additional information you provided, we've updated our software to support these devices and a new BETA version will be available soon, which should resolve the issues you're facing. I will contact you as soon as it's available.


Best regards.

Hello,


Could you please advise if the device was supposed to be supported in server revision 4.4.2? I tried it but still doesn't work with the device.


Thank you,

Calin

hello,


apologies for delayed response, the missing classes were added in the new update. Did you try excluding the device and including it again? I will provide a .dll file so you can replace it with current one and see if it's working.


Regards.

If you could provide your email address and the new .dll file will be sent to you.


Regards.

Hello, 

Initially I excluded the device, then update the server version to 4.4.2 and include the device.  

Please send the new .dll file along with the instructions to calin.birtocean@yahoo.com


Thank you,

Calin

can  you please send me the updated DLL to  icesys@gmail.com  , I have also same problem

If you install bOS Server BETA  you will get the latest ComfortClick.Zwave.dll

The integration of the  ZCOMBO from First Alert hasn't been solved yet. Are you experiencing issues with the same device?

Calin

I have already installed BETA , but still 4.2.2 

I am using NEO Siren Alarm



this  device for siren and alarm  and I supposed to  select two different music mode for siren and alarm  ,but it decided as a binary switch and I have one music for siren . alarm function not showing ( attached manual )

neo_coolcam_z_wave_siren_alarm_manual_eng.pdf