0
Under review

SMA cannot connect to Devices

Michiel Kenis 1 month ago in Devices / Other updated by Jürgen Jürgenson 1 month ago 10

When I want to connect my newly installed SMA Sunny Boy with the SMA integration, I get an unknown error. 

I provided the correct IP and password, but no luck there. 


When I click on "Get connected devices" I get a strange error, following a more generic error no devices are to be found. 

What am I missing here?


and

P.S.: I blurred some tokens, if they can be useful please let me know and I'll provide them to you.

Hi,


I don't believe that's an error just from your side.

I don't own any SMA device, and I get exactly the same error, even if the empty fields, and also with demo mode turned on.

So I guess it might be a software error from bOS side.

Hopefully anyone from ComfortClick might answer that.

Best regards

Hi Ricardo, 

Thanks for testing this!

As I cannot believe I'm the only ComfortClick user using SMA, I thought it has to be me. 

If someone at CC can check this out, I'll be very grateful! 

Best, 

Michiel

I have SMA Tripower, but can test in few days only.

Sorry, found time now:)

I got exactly same error, seems not connecting to SMA at all, no difference IP wrong or correct.

Hi,

It looks like the problem is not recent.

Had the chance to test in multiple versions, and only on an old 4.4.4 version I didn't get that error, so I think it's a coding problem from the bOS software side.

Version 4.4.4

It doesn't show up the error; Only the not able to connect error (which is true because there's no SMA device there);

Version 4.6.26

It shows up the error.

Version 4.7.0

It shows up the error.

Version beta 4.7.28

It shows up the error.

So the only option is to report the problem to CC team and wait for them to try to fix it.

Best regards

Hi Ricardo, 


Thanks for this through research. Two questions remains; 

- How can we repot this to the CC team? 

- How can I connect my SMA to my Jigsaw?


Best, 

Michiel

- Either you open a ticket on the top of this forum;

- Or wait for CC team to see our posts and see what they can do;


How is connection to the Sunny Boy made?


Do you connect the network directly to the Sunny Boy, or do you have a Webbox?

I've found a document about the API for the Webbox

Under review

Hello,

SMA products more or less switched to Modbus connection, and are using modbus address tables to control their devices, support for "native SMA communcation" is no longer supported. SMA driver in bOS will also sooner or later removed in the updates and only Modbus connection will be possible as their devices only support modbus connection.


Best regards. 

Hi there, 

Thanks for reaching out. Can you maybe provide us some information on how to connect our SMA using the Modbus connection? I also don't see any templates nor frames in the Modbus example... 

I would like to see how much power I'm generating with my Solar installation. 

Best, 

Michiel