+1
Under review

Cannot program KNX with Jigsaw and ETS 6

Kristián Vojčík 10 months ago in Devices / KNX updated by Joaquim Matos 5 months ago 22

Hello.

I having big trouble to programming KNX over Jigsaw with ETS 6 when I test for bus it return error but I can see data on bus with diagnostic but wehn I try to program something I got error Connection closed by remote device. Have anybody similar behaviour?

I worte to ETS about this issue and I got this reply: 


Team comfortclik please reply to this and dont ignore it as I cannot use Jigsaw with ETS 6 anymore.

Hey,

Yeah i'm having same problems. Weird thing is that at the start it didn't act that way, i was able to program all my devices but after i updated ETS6 to 6.0.1(Had problems with it crashing/closing randomly) it wouldnt work anymore. Now connection is closed by the device itself? At one point even the group monitoring did not work. I had to play with the bOS individual address to get it working again(address seems to change). Would be great if there was a work around as we need to demo jigsaw/ets programing next month. And my whole idea was to demo it without a separate ip gw, smallest kit possible.

How was you abble to get it working? For me it never worked. I also have issue connecting over secure IP interface with ETS 6, I dont know on which side is the issue.

I think it has something to do with the 6.0.1 update. I did my demo project with 6.0.0 and had no problems with it, multiple downloads and changes. But I had trouble with the debug window in ETS- it would close itself whenever I had device info open and I made the window full screen. So i decided to update it. After that im unable to reconfigure devices. 
I got the debug/diagnostics working by matching the individual number in ETS. If you look what the jigsaw is set to its not the same address that ETS uses. There are no problems controlling the devices from jigsaw if they have been configured. 

I was given temporary solution, on my ETS 6 licence I get to end of the year ETS 5 as well, I assume to continue working.

It works again if you update ETS6 to 6.0.2 that was released today.

Edit: I was wrong. It worked for 1 partial download then I got the same error again. It also messes up the application on the device so it does connect to it and does something... but

Thats bad really bad.... I dont know what now .... just wait for update but from who ? CC or ETS? ..... nobody seems to have answear to this.

+4
Under review

Hello,

sorry to hear you have issues programming devices in the latest ETS version. We tested a couple of different jigsaws and variety of MDT modules in the office since the latest ETS updates.

Local connection worked without any issues, remote programming however, showed the same error "Connection closed by remote device".

After some time and some more testing and programming even local connections stops to respond at certain point.

Same hardware works normally on ETS5.

We'll put this on highest priority now and try identify if the issue is on our side or the latest ETS version.

We'll notify you when some progress is made.

Best regards.

@ComfortClick Support, any progress on this? 

+3

Hello,

we're still working on a solution for the current problem with ETS programming.

Thank you for your understanding.

Best regards.

Hello,

I am using ETS6 . I started to run Jigsaw without problems with ETS6. Except AG import with  .knxprog files, but import ok with .esf files.

Have a nice day
JPS

Hello Pierre.

Have you manage to program KNX over jigsaw with ETS6?

Programing with ETS6 and jigsaw worked for me with version 4.9.8

Programming ETS6.0.0 and jigsaw worked fine, after upgrade ETS to 6.0.2, i have problems with programming

I’m not able to connect with ETS 6.0.4 and Jigsaw 4.9.8. There are some solution?

Hello Oscar,

we're aware of the current issue with programming using our Jigsaw and certain KNX devices. There are some tweaks required on our side, but there is issue with the latest ETS as well, which they're also working on.

Hopefully we'll be able to resolve this programming issue soon. Apologies for the inconvenience.

Best regards.

Ok, thank you for your reply. For your info, today i'm in the house and I can program throught the Jigsaw, but when i'm outside it is impossible.

Waiting for your news...

Best regards,

Óscar Toro

Hello Oscar,

do you have both TCP/UDP 3671 port forwarded for remote programming as well?

Best regards.

Yes, the Jigsaw is in DMZ zone.

Hello,

I have a similar problem.
I can't access and program the KNX installation via jigsaw(v4.9.7) and ETS6 (v6.0.4 build 4543). But it worked fine until about 2 months ago. Now the jigsaw does not appear as an interface, I have to define it, and when I try to access I get the message "failed to read device description from 192.168.1.38:3671, but ping succeeded".

Could you help please?

Hello Joaquim,

try updating to the latest bOS version. We made some improvements and changes and you should be able to use your Jigsaw and ETS6 normally.

Best regards,

+1

Hello,

Yes!

I did the update and it solved the issue. 

Thank you very much,

Best regards,