0
Under review

MQTT bug Internal Broker IP address

Pascal Platteel 1 year ago in Devices / Other updated 1 year ago 5

When setting-up MQTT and setting Internal broker to TRUE, then the local IP address is used of the client that is running the bOS Configurator (in my case my laptop). This is the wrong IP address and can not be changed! 

It should be the IP address of the bOS Server. 

When setting-up MQTT from the bOS Server, then the IP address is correct.

+1
Under review

Hello Mr. Pascal,

I’m sorry to hear about your problem, we’ll do our best to resolve it as soon as possible. Our developing team is already working on this issue so it will be resolved with the next update.

Best regards, David

I am also experiencing issues where the client will not connect to the internal server. Is this also a known issue?

External MQTT clients like MQTT-Explorer are able to connect to the internal MQTT broker.

I am using 4.9.1

And there is a bug setting a username/password when enabling internal Broker authentication. The password can only be set when pressing F4 in the Settings dialog. Not in the setting TAB. 

Also, setting a  username/password in the setting dialog, does not display the username/password in the setting TAB (see screenshot).

I am using 4.9.1

Hello Pascal,

thank you for reporting the issue. Have tried disabling Broker and then setting your Authentications and enabling Broker again? 

Have a nice weekend, David

Yes, I have tried disabling Broker and then setting your Authentications and enabling Broker again.

I can work around the issue, but not as it is meant to work.