0
Under review

Import of new KNX objects report that they already exists using bOS 4.9.0

Pascal Platteel 1 year ago in Devices / KNX updated by matej bregar 10 months ago 19

Using version 4.9.0. When importing new KNX data through xml file, the import tool shows that these objects already exists. But in reality they don't. Import does go smooth using export data from ETS6. 

Image 3509

Under review

Hello Mr. Pascal,

I am sorry about to hear your problem, we are here to help. Could you please provide us more information regarding the importation of the .xml file? We have tried re-creating the issue with the latest bOS version and the ETS6 but it worked without any issues. Any additional information would be helpful.

Best regards, David

I can send you the XML file by email. What adress should I use?

Hello,

you can send us email to: support@comfortclick.com .

Best regards, David

XML file send by email.

Hello Pascal,

thank you for sending us the ETS export file, we have imported and couldn't re-create the issue. Even though the group addresses are shown as already existing, if you select the items (right click - import) are you able to import them in the bOS?

Have a nice weekend, David


I think i saw the same thing with 4.8.106a. I was importing dali addresses when it showed them already existing. But selecting them "again", added them as new. 

Here is how i recreated it. Deleted manually 6 DALI GW1 values. Reimporting shows them as already existing. 

I can still import the KNX objects, even thought they have the status already exists

It is more a wrong status in the display. It does not block the import of new objects.

Same issue. New import works fine but adding in new values mark them as already exist and does not add them. Require extra step of finding them manualy and add them to import. Please fix it, it is annoying :(

Hello Kristian,

if you select the ones that show "already exist" and import them, does it not import them still?

Best regards,

Hello.

If I select them to force import they are imported into KNX but issue is that new adresses is label as already exist and if you dont force it to import it wont. Also new thing for me is that with some of datatypes as percent is incorrectly importing them. When I import percent for blind it import it as general 5.000 not as 5.001 scaled to 0-100% as used to be, it import as general so I manualy need to edit it to scaled value. 

Kristián,

could you provide an example where you get data types imported incorrectly (5.000 instead of 5.001)?

Any update? Issue still presisting.

Hello Kristian,

we're still working on resolving this problem. If you select the group address and change the value type from 5.000 undefined to 5.001 (scaling) does that work?

Best regards David,

Yes it does fortunately.

Hello Kristian,

great to hear that at least that can be changed so you can still normally use the devices.

We're working in fixing this issue and you should be able to see a fix with the next update.

Best regards.

Same issue here.

Just added a few new group addresses in ETS 5.7, export group addresses to XML. When I try to import in bOS 4.9.1, new addresses are marked 'already exists'. That was kind of a surprise to me, so I went to check the KNX devices but the addresses mentioned were not really there. So I choose to 'overwrite' the existing addresses.

If you have just a few addresses then you could handle it but when you have large project, then this could be a serious issue?

Hello,

the issue has already been resolved and will be available in the new release (hopefully this week).

Best regards