0
Under review

KNX connection type resets after reboot

Noel Fuentes 1 year ago in Devices / KNX updated by Michiel Kenis 11 months ago 7

Hello,

After upgrading bOS to the latest version (4.8.20), when I reboot the server (a clean reboot: Building/Reboot), the KNX conecction type sets itself automatically to KNX IP. I change it to KNXnet IP (Falcon), but with a new reboot, it changes back to KNX IP.

Is anyone experiencing this?

Best regards,

+1
Under review

Hello,

thank you for reporting this issue we will resolve this issue in new release version.

Best regards

Hello people
I have the same problem, I use the KNX-USB connection, and if I restart the server, its come back trying to connect via KNX IP...
any news from the update?
thank you!

Hello,

new beta was already released so you can try and download it and it should be working normally.

Best regards.

I now have automatically the "JigSaw" connection working, which is fine for the BOS config. But I lost my IP, which means I no longer can use this in my ETS software as Interface. How can I retrieve my IP? Probably by activating the KNX IP as "Type"? But as the JigSaw no longer has an IP, it cannot be autodiscovered anymore :( Any help?

I got it working by activating the "KNX Server" option. It's autodiscovered by ETS now (which has never happened before, so véry cool feature). But I cannot connect to the JigSaw as "The interface is not responding" :(

I'm crossed checked the IPs etc, so not sure what else I can check? 

Hello Michiel,

I am sorry to hear about your problem. Are you trying to connect locally via ETS or remotely? Did you test the KNX via bOS, does it work? Do you have enable KNX Driver and KNX Server (see the image attached).

MicrosoftTeams-image.png

Best regards

Hi there, 

Yes, I've enabled the settings just like your screenshot. bOS does confirm the "Connected = True" status, but on ETS, I get the "The Interface was not found" (see screenshot). The "Individual address" dropdown is also empty and I cannot change it's values...

I see a mismatch in addresses, but it's prefilled and I cannot change this in ETS, but I can in bOS. If I change the "KNX Server Individual Address" in bOS to 7.15.240, ETS provides me with another address; 3.15.240 for example.