Z-Wave stick Aeotec "Error connecting to device. No Ack" message

Francois Lesueur 3 years ago in Devices / Z-Wave updated by Simen Hagen 7 months ago 2


I'm using ComfortClick servers, but because I had a problem with one of the servers, I had to go back to a windows machine for a few days. 

Since I was using a Z-Wave Aeotec stick on the ComfortClick server, I thought it would be straightforward to use it on the PC : just plug and play.... well, not at all. I got the following message each time the server attempted to send a message to the stick "Error connecting to device. No Ack". 

It was driving me mad... I tried all kind of settings, and eventually found the solution - so just posting the question and the answer in case you face it so that you don't get crazy. 

When connecting the Z-Wave stick, Windows (7) is installing automatically the standard USB to COM drivers. But they are no good for the Aeotec stick. Some special Aeotec drivers must be installed in place of the standard ones. They can be found on 


This fixed the issue :-)

Hey Francois, how's it going? Hope you're doing well.

Thanks for posting the problem, and the solution, I'm sure it will save lots of time for those who face the same problem.

Best regards,


Same issue with my Z-stick 7 and Win10x64. Z-stick did not show up in ''device manager'' under COM port devices.

This driver fixed it: https://www.silabs.com/developers/usb-to-uart-bridge-vcp-drivers?tab=downloads