Prevent negative values from Modbus SMA

Michiel Kenis 3 years ago in Devices / Modbus updated 2 years ago 9


I'm reading values from my SunnyBoy SMA Inverter to shown the yield of my solarpanels in my bOS. 

I successfully connect to my SMA with below values:

Image 3064

It goes just fine as long as the sun is shining. Once the sun drops, the NaN value takes it's place and gives me the 

-2147483648 value; When plotting my daily yield, the few actual kw (max. 14 kW) vanishes compared to this ridiculous high value. Is there any way to prevent this kind of spikes? 

I've tried adding a new integer value which is set with a Program and corrected to 0 when the value drops below 0, but this still doesn't works out... Is there another SMA user suffering from the same? 



could you screen shot the mod bus device settings as well?

try bigendian data format looking at the manual.

Hi Andy, 

Thanks for your time, but changing to BigEndian gives me even stranger results... 

Ok have you tried it without the 30 in front of the address, and also try 774 and 776.

Not sure what model you have, as there is other info out there giving different registers as does the BOS examples on the web site? Address 209 for example but you'll need to do some calculations to decipher those.

Ignore me if you know all this just thought i'd point it out.

Negative to all. Killing the 30-lead or changing to 774 or 776 only gives me the "-1" value. So no dice there. 

I have a recent SunnyBoy (SB3.0-1AV-41 899).

I have modified the "calculation" program and this works out for me. But this doesn't seem right to do it this way? 

Maybe ComfortClick themselves can help us out on this one? 

Hola Michael, tengo el mismo problema que tú. como lo resolviste

Hi Michael, I have the same problem as you. how did you solve it?

Hi David, 

Not sure anymore, it's too long ago. If you have NO values (for example, no sun won't give you any value), you get this weird value. Are you checking the value when your installations is collecting sun?