0
Under review

HTTP device not working?

Noel Fuentes 5 months ago in Devices / Http updated by Fabien Fuster 4 weeks ago 23

Hello,

I've recently updated to version 4.6.17 and http devices with authentication stopped working since then. Funny thing is the http devices with no authentication keep working fine.

I use http devices with authentication to activate Mobotix cameras recordings and it doesn't work since the update. The "Response data" value is empty and no error is showed in the log window. If I use a program task to do the http request, a "no authorised" error messages shows in the log window, even though I'm sure the user and password are correct.

On the other hand, I use http devices to do a couple of tasks with Sonos and it's still working fine.

Any tips?


Thanks in advance.

Best regards

Under review

Hello,

a new version of bOS has been released and some fixes were made regarding your issues with authentication devices, so please try downloading the latest version and test it out.

Best regards.

Hello,

First of all, thanks for the quick reply.

I tried what you said, I've updated to the latest version and now it shows a "Unauthorized" error in the log window. Server has the very same configuration as three days ago, before the update, when it was working properly, so I'm pretty sure it can't be neither user or pass error.

Best regards,

Hello,

a new version is in the works which will hopefully resolve this problem.

Best regards.

Hello,

Thank you very very much. I really apreciate your effort.

Best regards,

Greetings to all
I look forward to that version, since my house is currently inaccessible and for me it is a tremendous problem.
I hope this is soon and really the solutions.
Greetings again

Hello,

the new version was released and you can try and updating your server and testing it out if everything is working as it should.

Best regards.

Hello,

The problem has been solved with the latest update. Thank you for being that quick. You're doing a great work. Thanks.

Best regards,

Hi. I just updated my own server to latest config and the netatmo driver stopped working. Normally it disconnects at server updates. But gets fixed by disabling and enabling the device. Now I just get a forbidden message in the log and the device goes to disconnected. All parameters for authentication etc is present. Any ideas?

Monitor : 07.11.2019 09:42:57 : General\Users\User : LastServerMessage : Devices : 11/07/2019 09:42:57 : Error : Devices\Netatmo : Forbidden

My log also shows this message shortly after I did the update:

Devices : 06.11.2019 14:26:45 : Error : Devices\Netatmo : Error connecting to device. Content-type at System.Net.Http.Headers.HttpHeaders.CheckName (System.String name) <0x70fd3370 + 0x000fc> in :0
at System.Net.Http.Headers.HttpHeaders.Add (System.String name, IEnumerable`1 values) <0x70fd32a0 + 0x0002f> in :0
at System.Net.Http.Headers.HttpHeaders.Add (System.String name, System.String value) <0x70fd3210 + 0x00053> in :0
at ComfortClick.Http.Driver.HttpDriver+d__10.MoveNext () <0x70d1b2c8 + 0x00297> in :0

Upgraded my server to the last stable version and having similar issues. Most of my http device are "not found" and a least one returns the following error :


Devices : 07/11/2019 22:52:54 : Error : Devices\Meteoalarm : Error connecting to device. Misused header name. Make sure request headers are used with HttpRequestMessage, response headers with HttpResponseMessage, and content headers with HttpContent objects. at System.Net.Http.Headers.HttpHeaders.CheckHeaderName(String name)
at System.Net.Http.Headers.HttpHeaders.Add(String name, String value)
at ComfortClick.Http.Driver.HttpDriver.d__10.MoveNext()

Strange wise, some other having headers data too don't return anything.

The most annoying is that all devices are not functioning anymore! For info, the last most stable version for http device was Beta version 6.14

I have now updated to the latest beta 2 or 3 times past couple of weeks. Still not working. It's a bit annoying not having the outside temp visible on my KNX switches. Do i have to issue a ticket to get response from the developers? Seems it's a bit random what they read on the forum regarding bugs.

+4

Hi Joachim,


I’m also experiencing weird behavior on http device. A ticket is open on their side and they are working on it... resolution should come soon.

Having the same problem. Device HTTP Not found. Running version 4.6.24

@ComforClick Any news about this problem?

Frederik, try latest beta (4.6.26), released today. It solved the issue (so far) on my side, at least over the last few hours since installed. I'll further test over the coming hrous/days and post back the outcome.

Didn't solve my issue :( I have updated the Netatmo specific thread with details.

+1

Just realize that I forgot to mention the following change needed :

Don't start any command with a "/". Instead, add this one at the end of the host address. Having done this change and upgraded to Beta 26 solved almost all my issues. Few remaining ones are still being reviewed by the bOS team.

Hope it will work for you.

Thanks for the tip, but I still get the 403 error.

Hi Fabien. Thanks! Starting a http command with "/" was the problem. Tested to change this before updating to beta and it works now. More or less all my HTTP Devices was with this convention and I had to change all before the problem was gone.

@ComfortClick Please update documentation!

+2

Nice to read it helped. However, for information, if this fixed most of my devices,  various other issues still exist with some other http devices but CC team is working hard right now to fix them all soon.

Hi,

Apparently I'm suffering from the same evil.

Lately I'm having trouble even on simple HTTP commands without authentication.

I've noticed because I have several HTTP devices, and most of them don't work.

And also several times my Weather stops working, and doesn't show up even if I reboot the server.

The funny thing, is that some of my HTTP devices are not working on my Jigsaw, but are working on other Grinder's, so it doesn't make any sense.

For example:

I was uploading my active power to the ThingSpeak IOT Analytics platform just for demo, and my Jigsaw doesn't even send  any value / or shows error connecting to the device. And the same device on a Grinder works... and both have the same bOS server version.

Second example:

Simple HTTP device which gets a text response, without authentication. Not working on my Jigsaw. Working on a costumer Grinder.

Etc...

Best regards

Hi Ricardo,

Since v4.6.26 and the above mentioned change posted on Dec 11th related to the position of the /, I've have no 403 error anymore. Instead, I get 401 error coming up, but data are being updated in bOS despite them. The 401 error is usually linked with a disconnection/reconnection messages...


Now, for testing purpose, I'm running the alpha version 4.6.30. If the occurrence rate of error messages dropped, they still exist...

Also, for info, I'm getting disconnection/reconnection issues for a device hosted on my own webserver on my intranet, but without the 401 error. No explanation why so far....

The bOS team is working hard on this topic and I'm sure your additional info will help them to narrow down the route cause. There might be something different in the code of the Jigsaw and the Grinder....

Best regards,

Just an heads up :

The new beta 6.31 is available. It improved the situation significantly for me as only one last device (Foobot API) show 401 error message. All other devices don't show error or regular disconnection messages anymore. Getting closer to full resolution here !

Best regards

The beta doesn't solve the problem with Netatmo (post command in oauth2/token):

Hi Andrej,

Does your device host url finish with a "/" ? I've found out that ending the url with any other character is creating some issues. You need to adjust the url and command accordingly....

For exemple :

hoslt url http://192.178.99.1/api/1.0/ and command ?method=system.getInfo will work

hoslt url http://192.178.99.1/api/1.0/?method= and command system.getInfo will not work

This might be one of the reason of your troubles. 

Regards,