0
Fixed

Modbus not working

Andy Gill 4 years ago in Devices / Modbus updated by ComfortClick Support 4 years ago 12

Hi There,

I still cannot get my modbus connection working since about 3 updates ago, does not seem to send anything out despite showing connected.

Previously there has been a problem with it constantly disconnecting and reconnecting but this is no longer happening.

I have checked my rs485 converter and it works fine with other software as does the device I'm trying to communicate with.

The log says the command has gone out, but there is no activity on the usb/rs485 converter as I would expect.


Any ideas?

This is the log entry when I change a value


Admin : 21/06/2016 16:41:32 : user : SetValue : Path: Devices\Modbus\Integer, Value: Value, Data: 500

Ok no reply from comfort click is anyone else having issues with Modbus or am I doing something wrong?

Does anyone know of any active forums where comfort click is discussed?


Cheers


Andy

+1

Hi Andrew,
I'm not working with ModBus but response time of support department could be improved.
Good luck with your problem.
Regards,
Fred


Since last update a lot improvements with Z-wave has been done, my whole system is working with this. I'm really satisfied at the moment.

Hi Fred,


Thanks, yes I agree the Zwave is much better and as it stands if I could resolve the Modbus issue I would be shouting about CC BOS to all, but the support is at times a major problem, the worst part is I don't know if I'm doing something wrong or there is a bug.


If the software was free and you had to pay for support I could understand!


Regards


Andy

Well I cant believe it...


Just changed the command delay time down to 10ms and it now works, not sure why though...


Not sure if I should blame my self or CC?


Regards


Andy


Under review

Hello Andrew,

we are really sorry for late reply, we missed your whole conversation due to e-mail notification issue. Did you already solve the problem?


Regards

I did but not sure how/why, after trying everything else, all I did was reduce the Command delay time down to 10ms and it all came to life, so yes all working now.

Ok, that is strange. And if you now put the Command delay back to 100ms it doesnt work?

Tried it over the weekend and no it did not stop working, however I tried adding another register and that did stop it, but a restart got it working again.

So cant really say what it was but all seems ok now.