0
Answered

Danfoss Living Connect compatible with comfort click?

Fred Hartman 5 years ago in Devices / Z-Wave updated 4 years ago 21

Are the Danfoss living connect radiator thermostaats compatible with the comfort click software
see link below for more info.

Datasheet Danfoss linking connect

Best regards,
Fred
Under review
Unfortunately we do not fully support Z-Wave thermostats for now. They will be supported in near future.

Hi,


Any idea when the danfoss living connect thermostats will be add to the software?
Currently I've add 1 thermostat to the bOS server, it's being recognized but just as a basic item.
see details.


see link to product, on this sheet the Z-wave commands are very well described.
I'm not a programmer, but It should not be that hard to make it compatible with comfortclick.
Afterwards you can use it for your marketing campaign and say you're compatible with Danfoss as well.

http://heating.danfoss.com/PCMPDF/Z_wave_living%20connect_VDHMB102.pdf

Thank you in advance!

Hello Fred,

we are planning to release new Z-wave driver in Q1 2016.


Regards

Is it still the plan to release this in Q1?


Thanks

Yes there is still plan to release new Z-wave driver in Q1.


HI Jure, did the thermostat/valve actuators get added to compatible zwave devices in the end?

Any news on this?

Hi Andrew,


the thermostat will be included in the next bOS release. We've made a lot of improvements and added new features that's why the new release will take a bit more time than expected. We're sorry for the inconvenience.


Regards,

Jure

Since last update to 4.2.2 thermostat is working great!
Unfortunately the Danfoss device is not able to measure temperature, so you need to use other equipment to create check local temperature to create a scene.

Hi Jure,

I've bought some extra thermostats after testing with 1 piece.
Now I noticed the temp setting point is not being send to the thermostat itself, Bosclient is showing new setting, but when I check the display on the thermostat the new setting has not being sent. When I press the wake up button on the thermostat the setting will change to new setting. But not without the manually wake up.
The wake up interval has not been changed in the Bosserver and stil default value of 300 sec.
Could you please investigate this matter?
In case more information is needed please contact me.

I'm using last version of Bosserver 4.2.6

Thank you in advance,

Regards,
Fred Hartman

Hello,

did this issue occur when you were testing with one device only?

BosClient shouldn't refresh the setting if the value is not set. We'll need to check this.

According to the thermostat's documentation wakeup interval should be set right after including the device. If it is not set then it uses the default value(30min).

If you set wakeup interval in bosclient and then manually wake up the device, does the new interval take effect?


Regards,

Jure



Hi Jure,

I just included another extra thermostat(just for testing proposes) and interval function has not been changed. so default of 300 sec is being kept.

1) I changed temp setting in Bosconfigurator and pressed on function requestvalue()


2) then monitor gives following info.


3) Setting is nog being changed in Thermostat, still old value of 15 degrees is active.

4) after pressing wake button on device the new value of 18 degrees is being shown immediately on display.


5) Monitor is showing this info after pressing the button.


The manual of danfoss is describing when no connection is available.
"If no connection can be made, the alarm symbol and the antenna symbol flashes"

Indeed the symbols are flashing on the thermostat device, but device is working properly except for changing setting point.

Do you need more info or is this sufficient to find a solution?

Regards,
Fred Hartman

Did you wait 5 minutes before checking the setpoint on the thermostat after setting it? When a device is sleeping it's not receiving any settings. The settings are stored on the controller and are sent when the device has woken up. You can wake up a device manually, as you did. Or set a wake up interval. This will force the device to wake up every n seconds. The device should receive all of your settings as soon as it wakes up.


This is why you can see the setpoint being set in Bosconfigurator but not on the device. We'll need to fix that with some feedback to the user if the device is in sleeping mode.


Let me know how it goes.


Regards,

Jure





Hi Jure,
Yes, I've tried it several times, also with my other thermostats, currently I've 5 pieces in use and another 7 in a box to install later. I've waited for several hours before checking the new temp. setting, but it only changed after hitting the wake up button on the device itself. When I checked the monitor on same time, then I noticed new setting was being pushed through to the thermostat by BosServer.

Do you need a complete log file maybe? If needed I can create one.

Regards,
Fred

If you could send a log that would be great. Have you noticed this behaviour on any other battery powered devices?

Hi Jure,
OK. I'll provide a log within some days.
All my other devices are working fine, they're all battery powered devices indeed.
I'll keep you updated.
Regards,
Fred

Hey Fred,


I've just finished testing. Temperature is set without manually waking it up. So all seems to be OK on my end. One the screenshot bellow is the information about the thermostat I've been testing with.


Hi Jure,

I've tested thermostats again, they're still not working. See my details below. This should be OK.
I'll send you the log files by email. Hopefully you're able to find the cause of this problem.



Thank you in advance.

Regards,
Fred

Hi,


I went through the log files. In Log monitor.txt status requests for battery and protection are sent multiple times in a very short time span (they are normally sent on device wake up). Was that you waking up the thermostat? Other than that all looks OK. We'll need to keep an eye on it.





Hi Jure,
I noticed monitor log was not exported completely, I'll send you complete file as well. And yes, I pressed device 43 very often in short time.
Regards,
Fred