0
Fixed

Z-wave stick Connection problem (Aeotec Z-Stick)

Fred Hartman 5 years ago in Devices / Z-Wave updated by ComfortClick Support 3 years ago 23

Hello,

Weekly I'm facing troubles with my Z-wave Stick, stick is dis- & connecting continuously.
I've tried to understand why it's happening, but couldn't find a good lead.
Are you familiar with this problem?

Suddenly it's stopping and everything is working fine without any problem.
Stick which I'm using is recommend type as described model(Aeotec Z-Stick) in the help file.

In my Win8 log file doesn't appear to be a problem with the stick or usb controller. I assume it's a software issue from bOS.

see attached print screen of log.

Log file


Any support is welcome.

Thank you in advance.

Best regards,

Fred Hartman

GOOD, I'M SATISFIED
Satisfaction mark by Fred Hartman 3 years ago

Is this the Aeotec Z-Stick Series 2 from the comfortClick site or the Gen5 that is up on Amazon? The picture they have on the ComfortClick is of the Gen 5 but the Series 2 product name they list is black. I just want to make sure I get the right thing.

Hi, currently we are supporting Aeon Z-Stick S2. Gen 5 has not been tested yet.


This is the stick which I'm using.

Aeon Labs DSA02203-ZWUS Z-Wave Z-Stick Series 2 USB Dongle


I've bought by a local dealer in the Netherlands.

Current driver version in my Win8 system, see details below.



Best regards,
Fred Hartman

Hi Fred,

so I've checked a few things and noticed the driver version is different, I have version 6.7.0.1.

First do a soft reset on the device. There's a button in the Network Configuration form. That will reboot your z-stick. If that doesn't work try to update its firmware.

If this doesn't solve the problem I'm going to need a bit more data. So firstly, turn on 'Debug Mode' in Zwave main node. Then turn on the Monitor tool(bottom left). Click 'Filter' and select the Z-wave node. The 'Record' button should be blue, if not, click it. This will record all the communication between bOS and the dongle. Leave it for a day or so, then save it and send it to me.


Regards,

Jure








Hi Jure,
I've done the soft reset for three times over the last three weeks, but it didn't solve the problem. I'll try to update the firmware version first. I'll keep you updated.
Thanks for your support.
Regards,
Fred

Hi Jure,

I've downloaded the software from the provided link and executed the firmware upgrade of the stick. drivers from usb-bridge controller software were not updated, so still version 6.7.0.0. (CP210x USB to UART Bridge VCP Drivers)
On the website of silicon labs (Link to driver page) I checked for latest version, there's no newer update available, 6.7 is latest.

Could you send me version 6.7.0.1 by email? or we.transfer.com

Thank you in advance.

Regards,

Fred

I just checked on a Win8.1 PC and the version is the same as yours. So that shouldn't be a problem. I think the next step would be to send be the monitor output.


Regards, Jure


Hi Jure,

I'm using Win8.1 as well. I'll activate the monitor, including the requested settings and forward it within some days, so you can analyze the log file.

Regards,

Fred

Hi Jure,


See printscreen of retrieved info from monitor. Do you need more information or is this sufficient to fix it?
If needed you may acces my BOS server to check settings or errors.


Thanks for your support!

Regards,

Fred


Hi Fred!


This is the first time I've seen an overrun error while working with zwave. I've done some research and it appears this is a hardware problem. The zwave dongle is not clearing its buffer fast enough to receive all the data, hence the error. Because of this I can't do much from my side. The only solution I can think of is to try installing a different dongle.


Sorry for the inconvenience.


Regards,

Jure



Hi Jure,

I've located the cause of the problem, if was the buffer setting of the Z-wave stick.
After decreasing the buffer, the problem didn't occur again. I've tested it with several settings and the settings as showed in the print screen below are working fine.


So you were right it was hardware related.
Thank for your support so far.

Regards,
Fred

Great! Also thank you for sharing the solution.


Regards

Jure

I'm having the exact same problem, but reducing the buffer only resolves it for a few seconds, could anything else be causing this?

Do you get the same "Port error received. Overflow" error? Have you tried increasing the size of the buffer?

I'll look into the issue first thing in the morning. In the meantime you can record the communication between bOS and dongle and send it to me just in case there's some other issue.


Regards,

Jure

Hi Andrew,

I'm still facing problem sometimes. The Fibaro wall plug has a lot of parameters which can be adjusted. I had changed some of the report parameters(40,42,43,45,47), connection problem was getting worse afterwards, so I changed everything to the default settings and connection problem was much less, It still exist...once a week instead of every 2 seconds. It's still very frustrating, but it is working for a longer peroid.
A good solution would be really nice!
I'll wait for the feedback of Jure.

Regards,
Fred

Hi Fred and Andrew,


could you try this firmware update


Regards,

Jure

Dear Jure,

I've updated the firmware some weeks ago, but it didn't solved the problem. Last week I've ordered a new Z-wave stick and replaced the old stick, see photo of new stick.



bOS server is in operation for three days now and the error didn't appear.
Looks like stick was main cause of problem. All other hardware hasn't been replaced or modified regarding parameter settings, etc.
I'll keep you updated if error problem is solved.

Best regards,

Fred

Dear Jure,
Finally I'm not receiving errors anymore. Problem has been solved with new stick.

Even the buffer settings can be adjusted to max positon, which improves the performance of whole Z-wave network, furthermore Z-wave Plus is much faster with importing new nodes in bOS.

Best regards,

Fred


Glad to hear the problem has been solved!


Regards,

Jure

Hi Fred,


Is your problem still resolved using the new stick? just about to order thought I'd check first.


Cheers

Hi Andrew,sorry for my late reply. Yes problem with error is solved!
Nevertheless I was facing new problem with Aeotec Door sensor which created the same connection error, but after consulting the support department of CC, I received a new Z-wave dll file which solved this. There was some bad scripting in the programcode.
New Z-wave stick is much faster than old stick, it works great.

Please keep in mind you've to exclude all devices from old stick and include them on new stick, this will take some time, afterwards all devices have new node id's, so you need to modify all your scenes, programs and redirect them to the new nodes.

Regards,

Fred

Hi Fred,


Thanks I've got the new stick S5 and its much better, haven't added everything yet as I have just moved, but lots to do over the coming weeks so I will see how it goes.


Cheers