0
Under review

HTTP device stopped working

Calin Birtocean 1 year ago in Devices / Http updated 1 year ago 2

Hello,

The http device stopped after few months working without any issues. Here is the debug message while trying to send the command:

Debug : 10/26/2018 19:45:41 : Devices\http : Exception : GetResponseCallbackWebException : The underlying connection was closed: An unexpected error occurred on a send. at System.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult)
at BOSCommon.Drivers.BOSHttpClient.GetResponseCallback(IAsyncResult result)System.IO.IOException: Authentication failed because the remote party has closed the transport stream.
at System.Net.TlsStream.EndWrite(IAsyncResult asyncResult)
at System.Net.PooledStream.EndWrite(IAsyncResult asyncResult)
at System.Net.ConnectStream.WriteHeadersCallback(IAsyncResult ar)

The encoding is UTF8 and parser type Json. 

Same command gets executed when it is launched from google chome browser from the same server where the bOS is installed.

Could you please advise what the problem should be? 

Thanks,

Calin

Under review

Hello,

what kind of http device is this? Is device working normally or is there also any issue with the device itself? Did you try accessing this device using web or any other software? Could be that there is something with the device so please check that. Also you could try adding another HTTP driver in bOS and use basic commands and see if it responds.

Best regards.

Hello,

The device is the ecobee thermostat and it is working properly. I cannot access directly the device, it goes through their API.

Here is the Host URL https://api.ecobee.com/

I can access the device using their android phone app.

The bOS server is running on a Windows 7 machine, but even when I load it to a Windws 10 machine I am getting the same errors for the the HTTP device.

As I mentioned before the http device stopped after few months working without any issues.

Basic command gets executed when it is launched from google chome browser or internet explorer from the same windows machine where the bOS is installed.

I have tried adding another http device and add only one command and still doesn't work with this API.

Could you please check as well the coding for ServicePointManager.SecurityProtocol = SecurityProtocolType.xxxx and see if it has to be redefined in bOS.

Thanks,

Calin