0

Image appers black

Luis Miguel Faustino 1 year ago in Devices / Cameras updated 12 months ago 8

Hello everyone
I have a problem in site. In the application BOSCliente i have a connection with the video camera and at the beginning everything was working correctly. The client had to change the router but now the image appears all black. I can access the camera externally and everything works fine but the application does not work. can someone help me?
Thank you
Luis Faustino


If They changed the router, did you make port forwarding for the camera? I had similar problems with my cameras on lan, so i made it so that the camera connects to the wan ip instead, not lan. Works fine so far. I have no idea why i couldnt get it to work on lan...

Hi,


The description is not quite clear about the installation:


Is the IP camera on the same LAN as the Server? Because if so, it doesn't matter if they changed the router, the Server grabs the image on the LAN. If you can see the server, the camera also can be seen.


Try to delete the camera from the visualization and add it again. If it keeps black, restart the server and test it again.


It would also help to post a printscreen of the configuration of the camera on bOS.


Please post the brand and model of the camera also.


Best regards












Hello

The IP camara is a Robin Telecom Development article nr:C01110. In the beginning it was working fine and the only thing that happened was the customer having changed the router. I had to configure the accesses again to Comfortclick to be able to access from the outside yet everything else is on the same LAN.

I show some images of the configuration of the camera in comfortclick, and the camera running in the application and a camera image through the browser. even so the black image appers.


Best Regards

Hey,


i actually got my camera(I have a zipato cam) to work on Lan now. Settings for lan: 

Settings for wan: 


Last time i tested this i coulnt get it to work on lan for some reason. Must have been my mistake on some settings. 

I think the %u and %p is missing in your settings. Try to add them and see if this helps. 

I don´t need to use the Username and a password because it´s disable in the settings of the camera....

I changed all the settings on the comfortclick of the camera and still not working

Hi,


I don't believe it has anything with the router, because everything is on the same LAN, so you don't need anything else.


I was able to get an external address to test out a video door bell from a costumer.


This doorbell, supports both JPG and MJPEG.


Incredible enough, I can see it while using JPG source. But with MJPEG it also shows as black.


Can it be something wrong with the MJPEG implementation on bOS?


You should try to find if the Robin Telecom doorbell supports JPG source rather than MJPEG for now...


Best regards


Hi

The maker send me a reply


"

I doubt if there is a malfunctioning in the intercom. All signs are
pointing in the direction of IP-network addressing issues, possibly
messages being filtered by the firewall. The intercom cannot reach
192.168.1.3:5060. So either communications is blocked, or the IP address
is wrong. There is nothing we can do about that. Perhaps you need to
speak to a local IP-network/VoIP expert to check the local IP-network."


But i I've already disabled all firewalls even from the router and in the server and still does not work


it´s solved... due to updates the comfortclick didn´t recogenized the user and password for th Robin intercom...

Removed all acesses and started working