0

Comfort Click Jigsaw 3 and PLC bad communication

Milos Jovanovic 3 months ago in Devices / Modbus updated by Jürgen Jürgenson 3 months ago 5

I would like to address an issue regarding the Comfort Click Jigsaw 3 device and the PLC controller. Communication is carried out through the Modbus TCP protocol. The initial problem involves the mobile application displaying the online status of the Comfort Click device, but it lacks successful communication with the PLC controller. Changes in values within the application do not reflect corresponding alterations on the PLC controller. This issue has been temporarily resolved by halting the operation of the PLC and restarting it, but it reoccurs after some time.

The second problem occurred today in the form of the unavailability of the mobile application. When attempting to log in to the device, an error is displayed: "Error connecting to server." Additionally, on the Comfort Click web platform, I noticed that the status of my controller is marked as offline.

I kindly request your expertise in diagnosing and resolving these issues.

I would like to add that comfort click works perfect few days and then suddenly this problems occurs. First problem is solved with stopping and starting PLC again, and second problem is solved with turning off power supply of comfort click and then turning it back on. But stopping and starting PLC and physically restarting Comfort click are not solutions I would like to resolve these problem so they do not occur anymore.

Hey

Does the error log show something when the modbus disconnects(also check if the error handling is set to reconnect on the driver)? Debug log should show more info, so i would leave it running for some time. Jigsaw shouldn't disconnect either. What version is it running on?

Hello, current version of bOS configurator is 4.9.40 but I can't log in to my device because status of my controller is offline. It was online working perfect for few days and now it is offline and I don't have any clue why. I will check debug log but first I need to get my controller back online. Do you have any idea why controller when to offline when it was working for few days?

If the jigsaw is reachable on lan then the public address has changed?  Do you use static wan ip or dynamic? It went offline probably because the IP has changed. You need to set the new public address again and correct port for it if you use custom port not the default 443 and set it as dynamic if needed.
 

Image 4731

There can be a number of reasons why it's failing:

  • Problem on the internet;
  • Problem on a switch, where the server is connected, if applicable;
  • Port forwarding disappearing (it happens sometimes in Portugal, depending on the stupid ISP's);
  • If you're using any service like DynDNS or NO-IP, please check the service, ports and if the public IP is the same both local and on that service (it already happened to me, public IP changed and the router didn't report the new public IP to the service (Jürgen already pointed this);
  • Server fail for any unknown reason, like software crash or something;

If you're using the ComfortClick Remote Access, which doesn't need port forwarding, then the problem might be other.

Can you check the installation locally, or at least ask the customer to give you access via AnyDesk or similar to a computer if it's hard for you to drive on the installation, and scan the LAN? Just to check if the server is working locally.

Best regards