0

Special character in HTTP device URL

Gabor Stepper 2 months ago in Devices / Http updated by Jürgen Jürgenson 2 months ago 3

Hello,

I am trying to access an HTTP API endpoint with GET request. It works from different kinds of clients (Chrome, Postman, etc.), but in bOS I get "Error connecting to device" error.


The only thing special about the request is the URL, which contains a "special" character, the colon :. This is because I can query data from a device which can be identified by its MAC address in the URL.

Has anyone experienced anything similar?

Thanks!

On jigsaw or windows server? Jigsaws http driver has some other problems right now, we need to wait for a update.
Have you tried to insert the mac as a string? if you open the Command string editor you can add your string in the properties. 

Image 4329

Thanks for your response! It is a Colibri server.

I tried your suggestion to add the MAC as a string property, but that didn't work either unfortunately.

Also tried on my local windows PC and it works fine. I guess Jigsaw and Colibri are both Linux based, so I have to wait for the update to have this fixed.

Thanks again!

Yeah if it works on windows server, then we have to wait for a fix. Some api's do still work on my jigsaw/linux - not sure why some of them stopped working.