0
Under review

Elering example library

Ohmin1970 4 weeks ago in Devices / Other updated by Kenneth Ström 2 weeks ago 13

Have anyone tried elering v2 from the examples library?

I don´t get any prices and I don´t know what I am doing wrong.

Local-Http ELERING API (27).bos

I made it, not sure if Comfortclick support has updated the public file yet - here is the latest with some fixes.

There are some tips&tricks to make it work right now. It work once it's running correctly. Importing it messes up some calculations and programs tho.

Here's what you need to do.

1) In the Programs folder you need to Cut&Paste back the calculation highlighted in picture after that run the program its under. Also check If every string has a date value. Every day value needs to have 0 in front that's why I made those programs.

Image 4293

2) For the string 3- %3 just write it manually or try to rewrite the value inside the program. It usually takes few tries - don't know why it does it yet. 

Image 4296


This needs to be done for every region. Or just delete the ones you don't need. After all the strings have values again Disable and enable the http driver and send the commands again. 

If you are using jigsaw then there are some other problems that im not sure how to fix yet. This template works on windows servers.

Under review

Hello,

we're updating the example as you go. It gets updated, tweaked, fixed, functions added constantly. Currently the latest (2.7) version is uploaded. Thank you for posting the example and continue to tweak it.

Best regards,

Are you doing anything to get this working on jigsaw?

Thank you for your answer. Yes I am using jigsaw. And this is all new to me. Still doesn't get it to work. I appreciate all the help I can get.

bOS support is working on jigsaws http driver errors I hope. This isn't the only http template that is not working on jigsaw anymore. 
My other entsoE price log template is still working on jigsaw though so its a mystery to me why some of them stopped working. 

Getting this error

Devices : 2022-11-08 21:41:38 : Error : Devices\Http ELERING API (27) : BadRequest (400) GET: api/nps/price?start=2022-11-08T%3A59%3A59.999Z&end=2022-11-09T%3A59%3A59.999Z

What could be wrong?

Time/Hour value is missing right now. Its inserting %3 for time. api/nps/price?start=2022-11-08T%3A59%3A59.999Z&end=2022-11-09T%3A59%3A59.999Z Right after the T there should be 21 for winter time or 20 for summer time.

Check this program/string.

Image 4302

Devices : 2022-11-09 18:50:05 : Error : Devices\Http ELERING API (27) : BadRequest (400) GET: api/nps/price?start=2022-11-09T21%3

A59%3

A59.999Z&end=2022-11-10T21%3

A59%3

A59.999Z

this is the error I get. Current price is working but an our wrong. All the 24 data are 0.

This command looks correct to me. It should get the correct hours too for winter. Are you using jigsaw or windows server? 

Another way to know which country's command has problems with command sent is to check the status code for all of them. If one of them is showing bad request then there must be a problem with one of its strings. 

You can delete the ones you dont need. If the current price is working recheck all the 24H strings again. If the calculation program is not working just cut&paste it, this should fix it.
 

Image 4310

+1

Now it´s working on windows server. Thank you Jurgen.

I have tried windows server now