Under review

Is Google assistant on the roadmap of Comfortclick?

Fred Hartman 7 years ago in bOS Configurator / Devices updated by Benjamin H Najarian 4 years ago 56

Will the google assistant being supported by comfort click?


Under review


we are well on track in this direction, Alexa being supported by Comfortclick. No release date cannot be set yet, but Google assistant is on our roadmap for sure.

Best regards.

Any updates on google assistant release ??



the google assistant is still in our developing plan, we're aiming more on releasing it on our new version of bOS (bOS5)



Google home now sitting on my desk at home. Just waiting for bOS5 then :D 

The google home functionality is enabled in the recent beta. Has anyone had any luck with configuration? I guess I need to enable a CC skill in the Google Home app. Can't find CC in the list there...


This shouldn't be in beta yet.

As you figured out, the google action for CC is not available.

It is now in certification phase. My guess is, it will take months to pass that.


In the latest available version it seems that the integration with Google Home is coming.
At least it appears in the Bos Configurator, in the API part, as it appears ALEXA

Meanwhile, you can try with IFTTT.



Any news about the release date of the Google Home skill ?




it's currently in development. It takes quite some time from google as well to look trough the software and confirm everything before we are able to publish it. We met their requirements, currently waiting for the green light to publish.

Best regards.



is there any news with the Google smart Home? 

Regards, Nati


is there any news about google smart home and comfort click

It will probably show up in this list when ready. 

Things are happening on the google home integration bit:

However linking my account is not possible:

Pressing "grant" gives this message. Has anyone had similar iussues?




does the controller you're trying to use Google home with have public access enabled?

Best regards.

It has a public IP and open 443 port with forwarding in my router. If that is what you mean?



correct, we will do some testing and try to resolve this issue, thank you for your report.

Best regards.

Exact same issue on my side, my grinder is accessible from the outside.


unfortunately Google home is currently not working on current version of bOS. Google home should be working in the next version of bOS.

Best regard.


Will the integration be "native" with all released languages? Or will it be the "ask comfortclick to turn off kitchen lights" which is less attractive IMO.

Also, Still not disclosing any details on when to expect the next version?



Hi, I am really looking forward to this. I expreminted with android tablets and autovoice continuous from tasker but this isn't stable at all. 

I want to purchase multiroom speakers with google assistant integration. So I can play music in every room and control comfirtclick everywhere without pushing any buttons by voice. I found a list here:


Any experience with google assistant integration in 3th party speakers? I am from Belgium, so not available yet on Sonos one.

Once the connection can be made, we can create a new topic to share experiences.



from current tests on new version, all your devices are controlled and used by using their phrase "Hey google".

Cannot say 100% regarding the release date, but new version is near completion and we're hoping on releasing it till the end of this month/beginning of next one.

Best regards.

good, something new about the integration of google home with comfortclick

Anybody who get Google assistatnt to work? If yes please make simple How to guide.

Hi. we are al waiting for an update of bos server. I think the integration of new services is poor in comfort click. However I very much like the logic you can use in the configurator and the user interface. 

I am looking for a way to set up easy communication between comfort click and home assistant. The latter has integration with over 700 products. Any experience?


Hi Christiaens.

I have integrate HomeAssistant with bOS.

Earier I used websockets but now using MQTT. With a script that subscribes to my HA mqtt-server I feed bOS via RPC. To do things from bOS Home Assistant there are a lot of techniques like http and so on that can be used if you don't want to script it. All items in bOS needs unfortently be created manually. What I know there are no way using RPC to creating items in bOS.

I really hope that a SDK/API will be relased soon for bOS. MQTT could be an other way to go so it will be easier to integrate with third partys. 

Thanks, MQTT looks interesting. Could you share your script? 

Hi Christiaens. 

Sure. Can you send me your email address and I will email to you.


Thanks a lot.

Sorry it was fichrist@gmail.com off course

Hi Fredrik,

could you please give me some tips or point me in the right direction to integrate bOS with Home Assistant via MQTT?

Any help would be greatly appreciated.

Thank you very much in advance.

Hi. I'm away but will send it to you as soon as I'm back home, this weekend.


The New bOS now supports Google Home and much more.

- New bOS:

New bOS Upgrade Instructions

- Google Home integration:

I have the latest version of bos server since yesterday. Still cannot connect to Google home. Same error message. Cannot update settings. Check connection. Anyone has a solution for this.

works in my house. Both latest version and latest beta which I'm running now. Port forwarding is set up in your system? Can you access your controller with the bOS app from external IP?

no it's not setup to be controlled from the outside. I don't want that. But why is that needed. Google home works on my wifi


When you give commands to your Google home it connects to Google's servers to interpret the command and it then communicates with your bOS controller to perform the command. That's why you will have to have an open port. 

ok I'll give it a try

it works now. Thx. Is there a way to couple tasks to a Google command? Like turn off all light in the kitchen


I only use scenes with Google home in my system. So if you have a "all kitchen lights off"-scene you could probably make it work. My most used command is "turn on good night scene" or just "turn on good night"

ok Found a solution already :) thx


Scenes and google home. What's the deal? I've tried device type = scene. Then scene trait = a task that turns off all lights. Refresh google home. Nothing??? Also lets say I want to have a google command "Screens Kitchen" and I want to set it at a value of 30% that seems not possible. You cannot set a value? Anybody?

guys from Ljubljana are really quiet

+1 on that.

When you say you have "a task that turns off all lights", do you mean a scene? Here is how it looks in my configuration. Works really well.

When it comes to sun shading, screens, awning etc, comfortclick has yet to implement the functionality. It's supported by google , but not with bOS. I have made them aware of it in a thread somewhere here in the forum earlier. For me it works if I set it as a light. Position is adjusted with "brightness trait", but it then acts as a light in the google app - and google answers that it turns the light to a given % etc. Not ideal.


Scenes still don't work here.

So I have made a task Watch TV. I can activate it in Comfort Click and it works. 

Now I've added a device under Google Smart Home named Watch TV with display name Watch TV, device type Scene and scene trait with scene activation pointing to my task Watch TV. 

Then I go to my Google Home App. First of all It does NOT show up between all the other lamps. I have to go to Settings - More Settings - Home and there I can see the scene Watch TV. When I try to say Watch TV. It's not recognized. 

Tried to move the scene to a room. Same thing. Not recognized. 

Why can't the scene show up in the main screen between all the other lamps. It's realy annoying that you have to go to settings, more settings, ….. 

What am I doing wrong here??

ITer van mijn voeten

En zoals altijd geen deftige oplossing van nen analyst. Veel blabla weinig dada. Zijn we gewoon

Hi all,

Any idea about how to enable Google API?

Although have the last released installed it's disabled



Have you tried to repair the installation or reinstall it after a complete removal ?



Google smart home node being shown as a Folder is indicating there are some problems with your Configurator application. As Fabien stated, try re installation, you can also try with a fresh new configuration, check if google home is working normally, then manually add configuration nodes in.

Best regards.

Hi when I try to connect google home to ComfortClick I get the following to authorise but there is not to select from The drop down 

please Assist


So far so good from here... Just unlinked my account and added it again on Google Home app, it shows all my servers to select. Best regards

Hi ,

What do you mean unlink , from google home ? 

I already had my Google Home linked with the ComfortClick.

So to test if something was wrong, I unlinked my ComfortClick skill on the Google Home app, and linked it back again. And didn't had any problems choosing the controller.

Best regards

Hi Ricardo , thanks a lot but my issue is that I’m not able to link at all , seems something at my google home end , since on the home connect app it is only finds 2 appliances although I have 5 WiFi linked to the home connect , I’ll try resetting the google home and will see from there