0
Under review

bOS Configurator editing problems

Grzegorz Kulinski 2 years ago in bOS Configurator / Themes updated by ComfortClick Support 2 years ago 7

Hello everyone.


Some time ago I discovered a very problematic bug. Now I'm using beta 4.8.20, but I noticed the problem in earlier versions as well.


I use the "Top Menu" and "Bottom Menu" parameters quite often, both in horizontal and vertical configuration.

This error causes editing problems. It's hard to describe, so I created a simple visualization (source program also attached). It contains two main frames, and in one of these are placed 3 subframes with buttons (red, green and blue).


Image 3435


Situation #1: The main frame with subframes is not the first frame on the page.


When we turn on the "Top menu" in a subframe, and paste a new object/objects (eg buttons) into the "Top menu" field, a problem appears - access to the objects placed in this field disappears. However, access to editing objects in the main field of each subframe still exist. However, it is enough to move the main frame or subframe, delete/add any object and we can edit the added objects again. Editing can also be restored by clicking on any problematic area and then pressing "Up" from the Themes edit menu. Unfortunately, pressing "Down" generates an error:

Image 3434



Situation #2: The main frame with subframes is the first frame on the page.


When we set the main frame with buttons as the first from the left, the possibility to edit objects placed in the "Top Menu" on all subframes in the main frame disappears again. The symptoms and possibilities to "fix" the problem are the same as in "Situation #1", but with one exception. If the green or blue subframe is set as first in the main frame, it is not possible to restore editing of the objects placed in it at all.

2021-10-12_Editor problem.bosBackup

Regards,

Grzegorz Kulinski

Under review

Hello,

could you please create short video explaining the problem? You can record screen with ShareX software.

Best regards

Hello,

thank you for reporting the issue. You can try changing the structure of the project. At the section where you have 4 buttons you can use less frames and then the problem does not occur again. You can check in the backup where I have added the 4th subframe. 

Best regards


2021-10-12_Editor problem.bosBackup

Hello,

Unfortunately, in your version, the bar is too narrow and the ability to adjust the brightness directly from the button disappears (and you have to open the slider submenu each time).


By the way, why the number of "bar steps" changes the appearance of the object itself?


This is very inconvenient, because when the customer wants to have access to smooth regulation directly from the button, you have to create either a very large button or reduce the number of steps (which affects the smoothness of regulation) or create complex structures, like mine.

When I started using ComfortClick a few years ago, there were two options in the bOS configurator to define the "bar steps": one for adjustments directly from the button and other, for the fader from submenu. And unfortunately, after one of bOS updates, one of these options disappeared and the other changes the accuracy of both sliders: /

Regards

Just my 2 cents.

I've noticed that bug too. And my workaround has been that if you select the buttons/frame and they dont show up as separate buttons(like its an invisible panel that has them all locked) You can write what ever in the Appearance Text field. After that it disappears and you can edit those buttons again. 

Best regards

Clever, but unfortunately it doesn't always work. From my observations, it is impossible to edit the object that is on the page as the first from the left. Therefore, when I need to change something in such a field, I move it to the right/down for a moment, edit it and go back to the previous position. It's a bit inconvenient, but at least you can keep working ;) I hope it's a trivial bug and it will be removed quickly.

Regards

Hello,

in the near future we expect to release overhaul of all buttons, we will see if we can do something regarding this issue. 

Best regards