0
Under review

Hue-connection not working

Peter Edwards 3 years ago in Devices / HUE updated by Tilen Suhadolnik 3 years ago 15

Got my hue-lights home today and started connecting them towards bOS. Sadly, the integration is broken.


When doing a wireshark-trace it´s obvious that bOS tries to connect to the hue bridge with user "ComfortClick" - no matter what username you specify in the configure-wizard.


The HUE API states that fixed usernames should not be used anymore as the are "soon" to be deprecated from the API. I guess that day has arrived - I tried to create a new user manually through the API but only got a json back with "username is not a valid command" or something like that.

Also - only to verify I connected the bridge against my OpenHAB deployment. That worked out of the box - was up and running in less than 30 seconds.


I believe that the user-creation part of the connection needs to be rewritten.

Under review

Hello,


try using the user name "ComfortClick". We will fix this issue in the next update.


Regards,

The problem is that its not possible to create a user with a fixed/user-defined name anymore. The correct method is to declare an application & device and then let the Hue-bridge return a random username to the application. This is done by doing a POST with body like {"devicetype": "ComfortClick_app#ComfortClick_srv"} to http://<bridge-ip>/api


A random username will be returned in the 200 response from the bridge. This should be used by the application.


I got this to work by creating a user manually through the API and specifyed the username i got in return in bOS. After a reload of the server I saw that the correct user was used when accessing the bridge - and my devices could be discovered and used. So, currently there is a workaround, but its far from pretty.. ;)


Regards,

Peter


I can't connect to my Hue. I have 2'nd generation bridge. I upgraded bOS to the newest version recently. The funny thing is that bOS found my bridge the first time I tried, but the config stopped after a few steps. Then I had to manually shut down. After I've got it up and running again the Hue bridge is not discovered anymore


I got my Hue light's to work using HTTP: device PUT command. But it not ideal.

My put command:

Host url: http://192.168.1.201/api/ltqwwQjAVp5I88s9fcCAHUvvlIxcNyugeZGN5UE4/lights/1/state

PUT command: {"on":%0, "bri":%1}


Best regards

Vidar Vestbø

[{"id":"xxxxxxxxxxxxxxxxx","internalipaddress":"192.168.1.201"}]

Are you using Windows XP?

If so, please try it on the newest version of Windows as Windows XP is not supported anymore.

I'm not sure if this helping you, but did you disable DHCP in het HUE bridge software. In case you've another device set to DHCP server, it will conflict with the HUE bridge.

I disabled DHCP in Hue bridge, still no connection.

Maybe I should do a fresh install of bOS?

I un-installed the bOS config and server. I installed v 4.0. In this version I have the ability to type in username for the connection: For testing I put in: ltqwwQjAVp5I88s9fcCAHUvvlIxcNyugeZGN5UE4. The connection where up and running in no time. But since my backup where v 4.20.10, I had to update the program. Now the problem is same as before. Please Help. I really like this software

I don't know what the problem is. I tested it with my own device and it works.

So, can you do the following:

- delete all nodes or clean your configuration by deleting "Building" folder in bOS Server installation folder (stop bOS service first and make a backup if you have anything to lose)

- start bOS service

- open configurator and login

- open the log in configurator and go to Debug tab

- click Record

- in configurator add HUE and click on Configure

Post the screenshot of log.

I followed your steps above.

- There is no record of HUE connections recorded after pressing Configure.


I un-installed everyting and installed v 4.0.

- Now I could connect to the HUE, using a username ( ltqwwQjAVp5I88s9fcCAHUvvlIxcNyugeZGN5UE4 )

- I could not control my ligths in this version

- I Exported HUE

- Then I upgraded the program to v 4.20.10

- I Imported HUE for previous version

- I added ligths and giving them the same name as before (Very importent, since it do not work if I use another name)

- Now it is working :-)

- But if I want to add lights later I have to use an App or someting to set up my HUE.

- Not Ideal. But working


I'm far from a computer expert, so maybe it could be wrong port setting or router setting.

Well that is very strange solution, but thanks for posting it and to let us know how you solved the problem.