BACnet IP - problem with displaying variables

Grzegorz Kulinski 4 years ago in bOS Configurator / Devices updated 4 years ago 4


I installed the latest Configurator in beta 4.7.25 and I have a problem with displaying variables on some objects. Analog variables are correctly displayed on objects with Control Type set as "Label". But when I connect analog variable to, for example, object with Control Type set as "UpDownSetter", a random value is displayed ("Setpoint temperature" button should display the value "13", but is display "18" despite the fact that the logger records value "13" all the time).
Binary variables are correctly written and displayed by the Logger, but a bit object with Control Type set to "Label" still displayed value "0".

Image 2805

Image 2806

A similar visualization in another building (server in beta 4.7.20) works correctly.

Has anyone noticed this problem?



Have you set the read type on BACnet nodes to SubscribeCOV? Maybe that's why they don't update?

I tried all possible refresh types (MinuteRead, CyclicalRead, SubscribeCOV). These variables are updated on a regular basis in Logger (new values appear periodically). However, on buttons and status objects that I mentioned in previous post, values remain unchanged.

How are these buttons made. Do you control the setpoint directly or do you have some program made that updates its value from bacnet.

Another idea is what if the ahu unit wont let you set the setpoint to 18c as 13c is the max allowed value?

Mystery solved :) When copying objects from another project, the Control "Value (Bolean)" parameter was reset to "In Alarm (Bolean)".

The problem with the temperature is probably due to errors generated by FAHU. Perhaps it doesn't accept and refresh sent value.

Thanks for suggestions. While creating a new button, I noticed difference :)