0
Under review

Serial Port - No Ack Error

Nuno Filipe 12 months ago in bOS Configurator / Devices updated 7 months ago 8

I'm trying to connect a Paradox security system to a CC Grinder, through a Paradox PRT3 module USB (COM3), and I'm getting a "Error connecting to device - No Ack" message" 10 seconds after connection, keeps trying to connect.

Can't figure if its a Windows problem (tried several configurations for flow control on port settings), Paradox configuration (Serial Port ON, Automation ON, ASCII Protocol, 9600br) or CC.

Any ideas?

Under review

Hello,

did you try these settings, found in the paradox manual? 

*From paradox manual*

Programming Sections
The following describes the programming sections which must be set when the Printer Module acts as an interface between a control panel
and a home automation module using the ASCII Protocol.
To access the Printer Module’s programming mode:
STEP 1: Press and hold the [0] key.
STEP 2: Enter the [INSTALLER CODE].
STEP 3: Enter section [953] (DGP-848) / [4003] (EVO).
STEP 4: Enter the Printer Module’s 8-digit [SERIAL NUMBER].
STEP 5: Enter the 3-digit [SECTION] you want to program.
STEP 6: Enter the required data.
The Printer Module can also be programmed using the WinLoad Security Software (V2.62 or higher) or using the control panel’s Module
Broadcast feature. Refer to the panel’s Reference & Installation Manual for more details. Please note that the serial number can be located
on the Printer Module’s PC board.

Best regards.

Hello,

I'm really using Babyware software from Paradox to program the security system and the APR3-PRT3 module is correctly added to the system and recognised by serial number.

The 3-digit [SECTION] programming codes for this module refer to the following parameters:

016/1 Serial Port Enabled (checked)

016/4 OFF:Send Event; ON:Residential Automation (Checked)

016/2/3 Baud Rate (9600)

016/5/6 Residential Automation (ASCII Protocol)

(in parenthesis my configuration, my translation from Portuguese - names may differ)

On the Paradox software there aren't any other parameters to configure for the serial port.

(in fact I'm using the USB port, recognised as COM3 on the Grinder Windows. Tomorrow i'll try another serial to USB adaptor on the serial port of the module)

Hello!

Have you solved this? I have the same problem..

BR!

P

Hello,

No I haven't.

Tried contacting Paradox Support but they only reply to distributors and asked me to contact my country distributor.

I also tried installing an Hyper Terminal emulator (Teraterm) that also couldn't get any data from the COM port. So I think it might be a problem with windows or firewall.

Also tried with other USB converter (FTDI) with the same result. 

Because of the quarantine I didn't get to go back, but 'ill have to take a look in the future.

GL

Nuno

Went back to my notes and had written that the module has 3 leds, Error (off), Rx (blinking) and Tx (off), so it still might be a problem with the security system, module or configuration.


Hi,

Can't really help directly, but I found out a KNX module from a company called Elausys, that uses the same principle for connecting the PRT to KNX through their module, because it uses ASCII protocol as well.

Maybe the options on their manual can help...

Check the pages 6, 7, 8 and 9, they show several options to set. Maybe it can help.

https://elausys.be/wp-content/uploads/2018/07/EVO-KNX-Paradox-KNX-Interface-Manual-R2.02.pdf

Best regards

Obrigado Ricardo,

The configurations indicated for this module manual are more or less the same I have on my security module, but on the last tab, "Report Options\Messages", the first parameter (Area affected by security) is set to 0 both on the manual and my configuration. Maybe this should be set to the area i'm using, unless 0 means all. I'll have to check this.

Also noted on the Troubleshooting section they approach the same tool I stated earlier, about the Tx led not blinking. This makes me believe I'm having a problem with the Paradox system\module and not with server\windows\comfortclick.

I've seen on this forum other people having the same problem (error messages) connecting to Tv's. Maybe there's a connection, or no connection in fact :-) 

I have the same problem