0
Not a bug

Unable to start HTTPS service on non-standard port

Adam Zanto 4 years ago in bOS Server updated by ComfortClick Support 4 years ago 3

I'm trying to run bOS server on specific tcp/ip ports. i.e. http on 9080, https on 9443. According to manual i have edited BOSService.exe.config as follows:


<appSettings>
<add key="EventServiceUri" value="net.tcp://localhost:16100/" />
<add key="HttpsServiceUri" value="https://localhost:9443/" />
<add key="HttpServiceUri" value="http://localhost:9080/" />
<add key="RPCServiceUri" value="http://localhost:81/" />
<add key="EnableRPC" value="True" />
<add key="ClientSettingsProvider.ServiceUri" value="" />
</appSettings>


But https connection does not work, http works fine. Changing back to 443 brigns it back.

I have already tried other ports, firewall is disabled. Checked on Windows 10 and Windows Server 2008 without success.


Answer

Answer
Not a bug

Hello,

please try to stop the bOS Server and delete the ComfortClick certificate in Windows mmc and start bOS Server back.



Answer
Not a bug

Hello,

please try to stop the bOS Server and delete the ComfortClick certificate in Windows mmc and start bOS Server back.



Hello, without certificate bos service won't start at all. Tried on standard and specified port.

Can you please send your TW to our mail and we will try to fix your problem


Mail: support@comfortclick.com


Regards