+2
Under review

bOS Client does not work after updating to iOS15

Alberto Gómez Zamora 1 year ago in bOS Client updated by Francois Lesueur 10 months ago 25

After upgrading the iOS version in both iPad and iPhone, bOS client app can't connect to the server.

+1

I confirm. I cannot run bOS visualization on any system, regardless of server version.

Under review

Hello,

do you get any error messages when trying to connect? Does the app open or does it crash when opening?

Can you double check the networking settings that are set correctly, also is the gateway activated on your servers?

Best regards,

+2

No errors. It try to connect for about 7 seconds and goes back to the selection menu.

Configurations work in the same network from the browser but not from the application. Before iOS update, bOS client worked correctly.

+2

I can confirm the error - reported yesterday by one of my customer.

Hello,

we're investigating the connection issue with the latest release. One thing you could try is to switch from automatic to manual connection type and fill out the local/public IP and check if the connection works with manual.

Best regards.

+1

Same error here. On two different IOS 15 devices.

-It works when changing from automatic to manual.

Exactly. It works on manual settings, unfortunately not on automatic.

+2

Hello,

Same error. For fix it temporarily I put the same local IP address to the public address.

Of course the externally connexion doesn't work.

Best regards.

+2

I have a similar issue. I upgraded my phone to ios15 2 days ago and sicne then I cannot login. You select the login user, the app tries to load for a few seconds and then jumps back to the user login screen. I tried another ios device and the issue repeats itself - before ios15 it worked, after upgrade to ios15 it didn/t

Hi, there are news with this problem?

Hello all.

After today's update of the bOS Client application to version 4.8.2, the visualization starts correctly.

It works! Thanks.

Hello,

with the updated application, everything should be back as it was before :)

Best regards.

Hi all,

It works in automatic mode again, but only while connected trough the wifi.

It doesn't connect out of the local network (4G).

Test done so far:

  • Re-created the instance
  • Re-install the app

Has this been fixed to work in celular networks? We do no want to update ios15 ahead of time

+1

Hello,

do you have public access enabled trough port forwarding or our gateway?

Best regards.

Hi,

I solved the problem by following your solution.

Thanks fir the support.

Alberto

Same happens to us. It seems that the public IP does not update on the bOS server. 

Best regards.

Hello, 

Same problem here : working with Wifi, not working with 4G. What is really strange is that it the same issue when using the browser : so, I would think this is not due to the client, but to some of IP address issue. 

I'm using port forwarding. 

Any fix / explanations / workaround for this issue ? 

Thanks, 

François 

Hello Francois,

is the server running the latest bOS version? Can you double check if the port forwarding is correctly set? If yes, you should be able to connect to the server. Also, check if the Dynamic IP option is set when setting your public IP in your license info for the server.

Best regards,

Hello ComfortClick, 

Thank you for your answer. 

Port forwarding is correctly set : before iOS upgrade it was working on 3 different servers in 3 different locations, and I haven't changed any of the routers setups.


Dynamic IP option is not set ; should it be ? What does it do ? 

I tried to activate this option from your web site, but I got a "Server not available. Check for open ports" error message which I don't understand : I can access bOS server from the Internet via Wifi, not 4G, but it's working via Wifi : so, ports are indeed open. 


I'm on server 4.7.0. I don't want to upgrade as each time I have upgraded I encountered many new bugs and had to spend a lot of time fixing them. bOS is the best software I've encountered in term of approach, coding, user experience, etc... but upgrades really make me nervous. I'm looking forward to version 5 that you said is coded from scratch and should fix those bug issues - when is it due ? 


Kind regards, 

François 
 

Wifi works on your local network so it does not mean that the port forwarding is working as it does not need it. 4G does need it though so please check if the port is actually open, you can use https://www.yougetsignal.com/tools/open-ports/ just insert you forwarded port there. If it shows closed It may be that your ISP has blocked some ports and you need to contact them to fix it or recheck your router. But if it shows open you should also recheck that the bOS port number is correct if you have forwarded different port for example. Dynamic ip changes every time you restart you router, static ip does not.



Hello Jürgen, 

Thank you for your explanations. 

Actually, I can access the server from a Wifi network outside of the server network. For example, I'm in the office, and I'm connected to the office Wifi, I can access the servers from the various houses located several miles away. Which means that the ports are correctly set-up. (and I have static IP addresses)

If I switch to 4G, I don't have access anymore. Weird...

Yeah that is weird. But have you tried other 4G providers? Or in the app is the account setup as manual config or auto, as iOS had some problems with it before? Put it in manual config and enter you wan ip with port to the public ip window.

Also you really shouldn't get the "Server not available. Check for open ports" error then. Even when dynamic is selected.

Hello, 

I've found a workaround : the "Private WIFI address" in the Wifi options of the connected Wifi network must be set to off. Both on iOS and on iPadOS. Then it's working fine both on the bOS client and from a web browser. 

If this option is activated, you can't connect to the server anymore, whether from the client nor from a web browser. That would mean that the issue is not in the bOS client, but in the bOS server : maybe it needs to get the client IP address to work properly ? That would be nice to correct this as it is safer to activate the Private Wifi address feature.