0
Under review

Manual configuration: problems with Local Address (out of home)

Ricardo Pinto 2 years ago in bOS Client updated 1 year ago 3

Hello,

I've noticed a strange behavior, when using manual configuration on the client app when I'm not on the same network of the server.

I've noticed this for a while. Not that it can't be worked around with a cheat, but it's there, and it's strange.

- I have a brand new, recently deployed Jigsaw on a friend of mine house; It's still not yet configured, so I haven't registered the device on the ComfortClick account; On the other hand, I'm using my own DDNS account until then, so I have to configure the installation as "Manual Configuration" on the app, so I can work remotely until I register the server on the ComfortClick account;

- So on the fields, I have the local IP address of the Jigsaw on the Local Address, and the DDNS on the Public Address;

- And then, when I'm out of there, that's when things get weird: Every time I try to connect the installation, two possible things can happen: if I'm on 3G/4G, it works; But when I'm at home over Wifi it doesn't work, and it stays on Reconnecting;


- When this happens over Wifi at home (out of the installation), either I edit the profile and past the DDNS also on the Local Address, or I have to go over 3G/4G to open the installation.


So, what I think that's happening, is that when I'm on Wifi at home, it tries to open the local IP, and as it doesn't recognize the server on that IP, it doesn't even try to use the Public Address.

It happens on every client (Android and Windows at least). On the Windows client, I can clearly see that it tries to connect forever to the local IP, and then tries to reconnect every time without trying to probe the public IP.

It also happens on every server I've tested, so I guess that's client app related only (not probing the WAN when not detecting the server on the local IP, when in Wifi/LAN out of home.

Can the team please check on this please?

Thanks.

Best regards

Under review

Hello Ricardo,

thank you for reporting this problem. Is the subnet at your home, the same subnet as the clients? If so, the app is probably thinking you're trying to connect locally so it throws the error. when you're using 3G/4G you're on a different network and the connection works. If the connection type is set to manual, we can't check/change these settings. It's advised to set the connection type to automatic (accessID) where these additional network settings/changes are checked so the connection works better.

Best regards.

Hi,


Yes, my subnet at home is exactly the same as the costumer.


I completely understand the Access ID thing, but there are lots of time that I'm not yet ready to register the server on the costumer e-mail, so I use my own DDNS temporarily on the costumer's house, so I can work remotely. Just to don't have to register the server on my account, and then delete it, and then register it on the costumer e-mail account.


I assumed, that once it couldn't connect via local IP, it would probe the WAN IP address. Apparently not...


It's like I said, it's nothing that a cheat can't do the trick, but in my head I thought that when using manual configuration, it would probe the LAN IP, and if not available it would probe the WAN IP.


Best regards

More than likely routing table, and firewall rules, basic but very complex infrastructure configuration. You're likely trying to access a public IP from your own network, your firewall on the router or outside of the router, is blocking such connection going outside of your own network OR should you not have strict firewall rules your routing table is not capable of knowing who to forward the ask for an IP that is outside of your network domain. If you edit the profile and bypass the DDNS is likely the later, you will need to add an entry in your routing table / s, subject to how you have set-up[ your private domain.