Under review

Android client and 4.8.5

Dejan Recek 3 years ago in bOS Client updated by Łukasz Klinger 3 years ago 6


After installing 4.8.5 update the client on an Android 7.5 tablet (latest available version) quit working and could not establish a connection to server. Clearing keys and cache did not help - still no luck. A workaround with Chrome browser IP direct connection and desktop shortcut works perfectly but it will be troublesome for bigger installations with many fixed tablet installations.

Under review


thank you for reporting this issue, we are aware of the problem and we're working on a solution as we speak, it will be released/fixed asap.

Best regards


Do you know when you will release the fix ? 

I can't use workarounds based on Chrome Browser on my tablets as for security reasons they can only access the bOS Android client. And I can't downgrade to a previous server version as I'm on Jigsaw. So, I'm stuck :-(

Thank you,



the issue should be resolved if you update the bOS to the latest version. Then update Linux OS of the Jigsaw as well, updates settings should be visible in your main Building node.

Please make sure you read the instructions and follow them. The update can take a couple of hours (depending on your internet speed) and disconnecting the server in the mean time can cause issues.

After the bOS and KNX update, you should be able to connect with your mobile devices.

Best regards.

Thank you for your quick answer. 

However, I don't have the update Linux OS menu on the building node :-(

Note that I don't have the KNX Jigsaw ; I have the Z-Wave Jigsaw, that has now been replaced by Colibri Z-Wave.

Is that the reason why I don't have that menu ? What can I do then ? 




Linux update is under Building node, Settings tab, Jigsaw paragraph - system update. It opens a window, which enables the Linux update. It took 2 hours to update on 100 Mbps download link. This has however NOT resolved the Android connection issue. Accidentally I entered the server address as http://192....:443 NOT https://192.....:443 and this solved the issue. Unsure if connection is running unsecured, which for me is not an issue since it is a local system behind firewall but anyways.

Hello, I have been working on comfortclic for about 3 years and there are still big problems with the android client,
the application disconnects and reconnects especially when changing windows, strange because I did not notice this error on OS or Windows, 
please correct it because most of my clients have Android phones and tablets.

ikona Zweryfikowane przez społeczność