Under review

UPS not recognised

Paul G 4 years ago in bOS Configurator updated by Fabien Fuster 3 years ago 10


UPSs in general do not seem to be recognised by bOS. Below some screenshots of very standard UPS devices (e.g. Eaton) connected to the very same PC running bOS (4.7) and WIN10

Even when I force the PC to run on batteries with the UPS, bOS does not recognise it. I have also tried to use the UPS generic but it will not work because the UPS comm system with the PC is through USB. Virtual COM ports do not work either as such is avoided in WIN10 for not truly COM serialised communication.

Image 2875

Image 2876

Hi, any update on this please? The UPS defined functions simply do not work.

Under review


does the windows recognise the UPS (do you see the battery icon on bottom right, like you would see on a laptop battery?)

Best regards.

Hi, my Eaton UPS works like a charm. By the question you raise it confirms you guys do not understand how the different drivers from UPS manufacturers works and confirm that the bOS UPS function does not work with W10. I guess not many bOS users actually install UPS therefore not many errors have been reported. Should you know how UPS works you would get to know that most, at least the standard (Eaton is one of those) and non-chinese UPC devices come with their own driver and utility to be ran on top of the OS, therefore when the utility detects a power failure in through the bios ACPI driver the UPS kicks-in, the problem of your bOS utility is that it ignores the bios ACPI state and driver and checks windows state, when actually Windows knows nothing about the UPS because it is being managed by the manufacturer driver / utility rather than running on a Windows utility. Check my screenshots. P.S. This is the same error you guys have in bOS when subtractions involve two variables that change, the subtraction is wrong when used on a graph. Or the same error bOS has handing wake-on-lan, bOS cannot put a system to sleep (e.g. NAS server) because you rely on windows i/o application facade rather than using the network level. Anyway, you guys need to improve QA automated testing.

Any updates? anyone know how UPS really works? Any reason the UPS functionality does not work?

Hello Paul,

our UPS driver is based on Windows HID USB driver (by default most of the UPS are recognised that way (APC, Socomec, Samurai power...)), which so far worked for every customer who used UPS and nobody realy complained about that, however we accept your comment and will try to do our best to improve it.

Can you explain the problem with substraction, what is wrong, can you send us an example so we can recreate the issue and fix it?

You cannot power off the computer via Wake on LAN by default, you would need some 3rd party software for that. WoL is ment for powering the computer/device on. For power off we only support windows devices and bos client needs zo be running on them, because bos client is the one that turns the device off.

Best regards


I've installed recently an Eaton 3S UPS, using the same piece of soft to manage it, and same issue.

Looking on the forum I found this post, and realize not all question have been answered, so to help to move on, let me bring further info.

Once the UPS connected over USB, I didn't see the battery icon on the Grinder Win10. I had to install the Eaton companion software. All data are visible in the companion...

According to the Network UPS tools compatibility list website, the drive is HID USB compliant, as per vendor.

Still, no way to get the info visible in bOS. Any idea to get it work in bOS or Win 10 to have bOS collecting the data ?

Hope these few add info will help.



does the Grinder find UPS as a battery in Windows? Our system is reading values directly from Windows. It is strange that even though you updated the drivers for UPS the UPS is not recognized in the Windows. Usually when you install the correct drivers on the Windows, the Grinder recognizes UPS as battery.

Best regards


Hi everyone,

Got it to work !

I found out that the Win 10 HID UPS battery service was not activated...

After launching the command "sc config HidBatt start=demand" and a computer restart, I was able to change the Eaton UPS driver manually to the "HID UPS Battery" one.

After a second Grinder restart, the battery is discovered by the OS. The battery is therefore visible in the power control panel and all parameter can be setup there. I removed then the Eaton companion soft.

As a consequence, the bOS UPS device get all parameters correctly :-)

Hope this can help others.


Speaking of turning off the computer...assuming the situation on Grinder servers:

Isn't bOS written on .NET platform? Isn't it possible to internally invoke the command shutdown /s /t 0, or other similar process? The Grinder is already running the software on the background, why the need of the Client to be running? I'm just curious...

Best regards


didn't mean the server but the client devices. Or your other PC's in your network.

Best regards.