Under review

IFTTT Webhook error Eproto

Gruyère Energie SA 4 years ago in bOS Configurator updated by Norbert Foldi 3 years ago 17


Since 2 or 3 months I have noticed that all my webhooks return the error below:

Image 2863

I think that a ssl certificat problem or error. 

What is the way to remove this problem ? Any Idea ??



Zero problems here, using WebHooks (from IFTTT > bOS). I'm using the RPC on bOS, and use WebHooks everyday to fire up sleep mode etc (as widgets on my Android phone).

Is your problem from IFTTT to bOS or the opposite?

Best regards

Thanks for your answer.

The problem is from IFTTT to bOs. The command from bOS to IFTTT work fine.

You use the rpc with an "https" command ?

I don't understand because the problem appeared a few weeks ago.

I try with Roomba iRobot but the result is the same .... error ssl


RPC is only available over HTTPS for a long time (since the new RPC version was published).

I don't have any problems from ifttt to bos.

So you're having problems with ifttt > roomba?

Well then, that means that bOS has nothing to do with the problem...

Probably it's some problem on ifttt services, but probably based on your location (don't have any problem here on Portugal).

Where are you at?

What server are you using?

Jigsaw? Grinder? Own server?

The problem is with Roomba and Husqwarna (two robot on my home). I try yesterday to integrate the Roomba on ifttt and the error is the same.

In my case I use the RPC/API/setvalue.

My applet worked fine for a year and suddenly I have this error.

I have the beta version 4.7.30 and the server is mine but identically same of Grinder (Intel NUC).

I try with Callfunction for testing, but is the same issue.

Comfortclik support have you an idea about this issue ?

Under review


you mentioned you started having this errors 2-3 months ago? Do you remember if they started after you updated bOS ?

We tested RPC/IFTTT using webhooks to control devices in the office using the latest bOS beta version and everything checks out and everything is working here.

Looking trough the update notes for our betas, there weren't any changes done on the RPC service so the communication should be working normally.

You tested directly roomba/IFTTT and you get the same results?

Best regards.


I do not remember if the issue appear after updated bOS.

I use the version 4.7.30 but the issue is present before this version.

The request from bOS to IFTTT work fine. 
I have no idea where the problem comes from ???

In few days I try with an other bOS 4.7.0 to test if the problem is the same.

Best regards.

Hi there, 

I can confirm I got the very same issue with my IFTTT + RPC connections since a few weeks ago (I did install the beta though). 

So very interested as well for a solution. 

Best regards,


I can confirm this issue has been fixed in bèta 34. 

RCP running as fine as before. 



Where you find the beta version 34?

For me the version 33 not work for the RPC ifttt

No sorry, I am mistaken. It's 33. 

But fixed though. What error do you get?

Always the same error that you see on the start of this thread.

Can you past your URL and body please? 

(Please be aware to hide your credentials in the URL !!)


I have the same problem on a Grinder Black box. I have an own domain, because my IP can change. I tried to set this domain as public address and restart bOS (i can even see the address has been correctly under the license settings). When I try to reach the box through https web browser I get certificate error (because the provided SSL cert is not valid on our domain). I have tried to find the certificate in the manager but I don't have any under Personal. What I found is a CC-Grinder cert under Remote Desktop, but based on HTTPS cert ID these are not the same, so I haven't touched it.

Do you have any idea how can I make a new cert for my domain (It's not a problem if i need to provide my own)? Then the HTTPS connection won't have any problem and I think the IFTTT with webhooks can work without any SSL problem.

Thank you in advance!