0
Under review

GraphPlot object problem

Grzegorz Kulinski 1 month ago in bOS Configurator updated by ComfortClick Support 1 month ago 4

Hello All.

After the last update to beta version 4.7.24, the display of graphic objects has changed: flat, single-color buttons have been replaced into buttons with 3D effect with a color gradient. No object parameters are available that will allow programmer to revert to the previous (better ;)) display version.


Buttons from version 4.7.22 (flat buttons):

Buttons from version 4.7.24 (gradient buttons):

Additionally, from several versions (at least since beta 4.7.18) there was a problem with creating / editing a GraphPlot objects. Every editing attempt triggers an unhandled exception by BOSConfig.


Some detailed data from logger:


See the end of this message for details on invoking just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.NullReferenceException: Object reference not set to an instance of an object.
at BOSCommon.References.Common.ReferenceBase.GetObjectName()
at ComfortClick.Tasks.Config.DataLoggerEditors.PlotParametersForm.CheckIfCanBeAdded(ThemeObjectReference newCommand, ThemeObjectReference editedCommand)
at ComfortClick.Tasks.Config.DataLoggerEditors.PlotParametersForm.OnEdit(Object sender, EventArgs e)
at System.Windows.Forms.Control.OnDoubleClick(EventArgs e)
at System.Windows.Forms.ListBox.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

The log is very long (if needed, I can add it all).

Regards,
Grzegorz

Hey

I can confirm this has happened to my config too with the last update 4.7.24. Changing them back to flat is not possible as the button for it is missing. 

Hi.


I noticed that the first problem arises depending on the object's "Back color" / "Back Color On" setting. When the color is not set, button is displayed correctly (flat, no gradient), but when a specific color is selected as the back color, a gradient and a 3D effect appear.

Regards,
Grzegorz

Fast update.

I reverted back to the previous version 4.7.23 and the buttons look normal again (flat, solid color). The application edited in the newer version 4.7.24 ran successfully on version 4.7.23.

Regards,
Grzegorz

Under review

Hello,

thank you for reporting this issue, we'll try to fix visual anomalies as fast as possible.

Best regards,