0

Jigsaw - Problems with email, weather, http devices

Ricardo Pinto | visiontech.pt 5 months ago in bOS Server updated 5 months ago 3


Hello everyone,

I think probably most of the problems I'm describing here were mentioned in other posts, but it's getting really problematic, and I'm looking forward for you attention:

I'm using Grinder servers on every costumer, but I have a Jigsaw at home, running version 4.6.26, and there's where I'm getting all of these errors / bugs.

My internet service is quite unstable to be honest, and I need to reboot the router quite often. But the electricity is stable, and Jigsaw is operational with almost none reboots. At first, I thought that problem might be from the unstable internet, but now I'm stating to think that the problem may be software based.

The local and remote access to the Jigsaw is ok, and never had any problems with that.

The problem is that I've noticed that I have several services which actually don't work, or just work from time to time. And they are:

SMTP Email sending


My Jigsaw doesn't send any emails... Gmail, own mail server, nothing works. Today I've tested exactly the same SMTP configuration on my local laptop bOS server, and it works. But not on the Jigsaw. It doesn't show any error, it just doesn't do anything.

Reload and reboot doesn't solve anything.

I think I probably just seen my Jigsaw sending 1 successful email, and that was kind of several weeks ago.

Weather service


My weather service also doesn't work. Most of the times I see an empty error image of the weather on the visualization. On the weather node, if I add my City name on the location name, it disappears.



HTTP Devices


Simple stuff like making an HttpRequest on a Task or Http Device, without any authentication, doesn't work.


Example of a HttpRequest not working:

https://api.thingspeak.com/update?api_key=xxxxxxxxxx&field1=100

Resuming:


Reboot, Reload, Factory Reset, none of this actually helped at first.

With a fresh Jigsaw factory reset, I had the same problems.

Then, after a configuration restore, my email started to work. And apparently weather too. The question is, for how long. Because it happened before.

Is there something wrong on Jigsaw code? Isn't bOS sharing the same code that on Grinder? I assume that the software is developed in .NET and using Mono on Jigsaw or something.

The question here is, am I the only one with problems? If not, has anyone noticed this issues? Or am I being too picky?

My configuration is not that complex. It's true that I do a lot of testing, and complex logic, etc, but the configuration and visualization is pretty "light" actually, so I know I'm not pushing too hard the Jigsaw.

Best regards

Hey,

As i update my test jigsaw to 4.7.0 i cant test 4.6.26 anymore.

But i can tell you that for me SMTP(i use gmail) works, default weather works too, but i dont use it actively and ive made my own with http basic from a local weather station is working and it is without authentication.

So maybe try to update to the newer version as they fixed a lot things. So far ive only noticed two small bugs - You cant copy and paste modbus devices - it will remember some of the old nodes after the rename, so some nodes will need to be changed manually. Also you cant change multiple templates for nodes in groups.

Hi,

I've also updated to 4.7.0 yesterday.

I have to say that yesterday, after a factory reset and a configuration restore, the weather worked, smtp, etc...

And today it happened again. No more weather (just the error image as described above), no smtp emails, etc...

And from yesterday till today, I haven't changed anything.

The electricity is fully stable, and didn't had any power outage.

The only thing that happens, is my internet access which is quite unstable, so quite often I loose the internet access. But either I wait, or just reboot the router.


But even with unstable internet, it doesn't make any sense that the Jigsaw stops the weather and the emails. To get this clear, let's say that my internet fails and I reboot the router: Even if I reboot the Jigsaw gracefully on the configuration, it should see that it has internet again, and those services start to work again. But it doesn't!

What it looks like, is that somehow, when the Jigsaw can't access internet or something, something blocks on the configuration, or on the code... or whatever. But that's something that doesn't fix with a soft reset.

I did a factory reset yesterday, didn't worked, restored my configuration, it worked. Today it stopped working again.


Don't know what else to do...

Best regards

I just rebooted the Jigsaw right now. And it started to work again. But I changed the location from Portugal to United Kingdom. Just trying to find any relation with this issues everywhere...

If it was a "simple" network problem, then I wouldn't be able to access my Jigsaw remotely, and I can. Always, even when this issues occur.

I can use RPC, locally, and remotely with IFTTT.

I can use HTTP devices with my local HUE hub.

Etc...


Weather, Emails, HTTP devices (not in LAN), stop to work with no apparent reason.


Best regards