0
Under review

Public Address failing to update

SYSGLOB LDA 6 months ago in bOS Client updated by ComfortClick Support 6 months ago 3

Hi all.

Currently I have 2 different clients complaning about the remote access. I already saw that the problem is in the Public Address updating.
When the internet provider change the public address of that house the bOS is not updating in the client server. So when the client connects to is Access ID, it goes to the previous public address and fails.


Anyone with this problem?


Thanks all for the help.  

Client needs to talk to the ISP and order a static wan address.

Or they/you can use some dynamic ddns service like Noip that then needs to run on the server and updates the dynamic ip for ddns.

Hey,

Isn't it suppose bOS server to update the wan ip address to the account profile?

Then what's the point of having "Dynamic IP" true or false option on the profile?

I'm pretty sure bOS updates the wan ip address if it changes, and I can tell you why:

A couple of weeks ago, one of my costumer changed to another ISP router, and didn't tell me. On that morning I was working on his server, and suddenly lost the connection. After a few minutes, the bOS Configurator was trying to connect to a different IP, that shows when trying to connect, so I found weird the new IP address and called my customer asking if he had reset the router. That's when he told me about the new ISP router. So I just port forwarded in the new router.

So in practice, the ISP router changed, bOS server updated the account profile, so when using Accces ID as normally, the client app was already trying to connect to the new wan IP address, even without having the port forward (of course that without the port forwarded, it was showing connection error, but at least it already knew the current wan ip address).

So I believe you have something else there...

Check if you have "Dynamic IP" set to True on your account profile for those Access ID's, and refresh in the license page.

Best regards

Under review

Hello,

as Ricardo mentioned, when setting the public IP, make sure you have Dynamic IP checked.

Best regards.