0
Under review

Key Profile

SYSGLOB LDA 2 months ago in bOS Client updated by ComfortClick Support 2 months ago 8

Hi bOS.

Today I notice that everytime we enter in a server you need to confirm the "Key profile must be obtained from the server...."
Before you only need to do this the first time your device enter that server! 

Is that normal from now on?!

Reporting in that this does not happen to my projects. Maybe somebody is deleting your device from the users menu?

I don't think so because this is happening in different servers (I tried in 4 different servers (clients)).
If you close the bOS app (kill it) and then enter again it will ask again for the key profile message! 

Can you check that Jurgen?

Thanks.  

Just did a new test, closed the app and reopened it, checked different buildings. All logged me in without any errors. Have you tried a different device too?  Or have you looked at the devices token's do they dissapear when you log out the device? You could also try reloading the server from the configurator, see if that helps.

Hi,

I can confirm that's also happening to me, but not in every version...

Using bOS Android client version 4.5:

- It shows the "Profile key must be obtained from the server" on my bOS Server 4.6.20

- Doesn't show the message on at least two random customers with bOS Server 4.4.4

Best regards

I also find 2 clients with version 4.6.20 and in one you always get the message, and the other don't. 

Strange...

Hey,

I've noticed that when you have connected with a administrators account and then change back to regular user, it ask for it sometimes or tells you the password may be incorrect at the first login attempt, second login works with no password changes. This has been happening on 4.4.4 too, and i think its because bOS does not copy the device to the users account when its already under admins. 
Have you tried to delete the device and then reconnect it?


Strangely none of my current projects are affected with it right now. I tested both versions 4.6.20 and 4.4.4

Hi,

Deleting the device and reconnecting did the trick for me. Thanks Jurgen!

About logging in with admin and change back to user, I don't think that was the problem, as my installations are all running with admin user.

But deleting the device and reconnecting worked for me, no more "Profile key..." message so far... probably the device token needed to refresh or something..

Thanks

Under review

Hello,

thank you for reporting this issue for the new version. We'll look more into this issue and try to identify the problem and resolve it as soon as possible.

Best regards.