0
Under review

Clients logoff emmediately

van der heijden Stefan 3 months ago in General updated by Jürgen Jürgenson 4 weeks ago 17

Hello,

Suddenly without any change of configuration, all of my clients are logged off emmediately after logging on. It keeps just auto logging on and off without showing the gui. This is on windows, ios and even in just internet explorer.

I had this before a few weeks ago and fixed it with a restore of an earlier backup of the config, but now I'm sure I haven't changed anything. I'm running on the last stable release. 

I can offer the config on the server though.is there a logfile  I could take a look at?

Regards,

Stefan 

Hi Stefan,


You can access the logs by clicking on the bottom left corner :

You get access to the following options :

Hi, thanks for your reponse.

I know that log inside the configurator, but unfortunately it only tells me that the user has been logged in (again and again)

The debug doesn't give me any more information either


Would it be possible to see logfiles from the webservice itself?

it turns out to be something with the user I have my devices logged on with.

I've created a new user, deleted the old one and recreated it... problem solved!

But it's still strange behavior

Hey,

I have same problem right now. My phone connects correctly to bOS but clients phone keeps login out and in. I deleted the user, reloaded config but still the same error.

Connecting with the admin user works fine.

Connecting with Regular users account does not stay connected. I deleted the users accounts but after adding it back nothing changes.

bOS server version is the latest stable.

Edit:

If I make a new user, I cant connect to it. I made kaamos test user. It does not show my device under it, connecting to it does not work. Only the admins user account works. Changing the privilege on the regular user account does nothing. Changing the login name or password does nothing. 

Stefan, did you do anything else do get it working? Following your steps does not work for my setup.

have you tried the same with another new user?

My new user worked instantly

Yep, I added a new user. Deleted the old one, but couldn't connect, right now i gave regular users the admins login info so they can still control their stuff. Imported back the old users and deactivated it.

Hoping that Comfortclicks support gets time to look at it. 

the only difference I notice in our setups is that both of my users are admin.

you could try to give a new user admins rights and see what happens

Hey,

So I got it working at first it seems, with administrator privileges. Its still a annoying bug, because i had made at least 3 logics/programs for each users device, for login users activities like who opened a door etc.  i had to manually import them back one by one.


AND then my other original administrators account wouldn't work! So i had to delete this too.

Right now i can login with both accounts.

Under review

Hello,

we're trying to recreate the problem with no success. All users work normally, regarding of their privileges

For future troubleshooting, if you have an administrator user, login works normally, if the user is a Guest, the client reconnects and stays in the loop? Also, do you have different themes selected for different users? Did you also try, re-adding the controller in you client device as well?

Best regards.

Exactly - Administrator account worked fine for me yesterday, But the account with Users privileges stayed in a loop. After i deleted the users account and readded(as a admin) it and connected to it(With success) my administrators account would loop. So i had to delete that too and readd it. 

When i Deleted the users account and imported it back from the backup(with users privileges) it would loop again.

All users use the same Theme

in my case, I had only 1 account before (obviously an admin) which stopped working suddenly.

I had to restore a full backup and it started working again for a couple of months

When it happened last week, I had to create a new user (with admin privileges) and recreated the first user as well.

I have already tried to re-add the controller to the client device, even tried to open the webservice on a normal internet browser with no success

Hey,

Reporting that same thing happened again, but this time both our User account were not able to login(Both User accounts were set as administrators this time), log shows user logging in after every 6 seconds(stays looping). Last time only one account had problems logging in. Deleting and readding the user accounts as new user and copying back the devices fixed it again.

Hello,

thank you for reporting this problem. Which version did this occur on?

Best regards.

Hey

It happens with the latest stable update 4.6.1. I have tested the new update only with small projects,  i have not updated our big buildings yet.

Regards

Hello,

does this happen on every client device that tries to connect to the server? You could also try to remove and re-add the theme and adding it again.

Best regards.

Yes it happens on every device. I didnt try deleting the theme, will try that if the bug comes back.

Edit: Also id like to add that it would be a great feature, if you could copy users as a backup inside comfort. right now even if i disable the user it still goes over the user limit. Imo it shouldnt count as a active user if its disabled.