0
Under review

bOS update to 4.5.0

Kristián Vojčík 3 weeks ago in bOS Server • updated 6 hours ago 17

Hello. After starting to update all of our installations I noticed that bOS Configurator can not connect to updated one, it says Downloading Configuration, then Configuration is loading. Please wait and that repeat. bOS Client has no problem connect to that installation. Any solution for this issue? It seems that is case of all devices updated to 4.5.0.

Hello, I can confirm same problem. After upgrade bos Configurator can only connect to servers (Jigsaw) within the same LAN. On remote connection it keeps loading configuration forever. bOS client and web interface works fine.

Same problem occured in latest beta release.

Adam

Hello. Same thing happened to me. I'm trying to connect on remote using port fordward and VPN connection too.

Same with me, but seems to resolve itself if you uninstall and then reinstall configurator.

Andy

Reinstall didnt fix it for me. I try remove all files from C: drive and than install it but no luck. 

Hello.
Good catch guys. As you know, with every new version few bugs can pass by unnoticed and the help of our community is crucial to tackling them all. We are working even harder these days to solve them and your reports are very important. Thank you and we will have updates soon.

Hello,

I'm experiencing same problem and some others.

Eventually, the remote connection fixed itself, with some reconnection issues though.

Other problems I've noticed are related to scenes (not working properly until I rebooted the server) and dataloggers (not showing actual value on a opengraphbutton).

I've only updated the server in my house. I think I'll wait to update our customers' ones. Meanwhile, I'll try to keep on testing the new update and let you know.

Best regards

After update to 4.5.0 , https connection doesn't work. I already have canceled the comfortclick certificate. How i can fix this problem? 

Under review

Hello,

are you using Jigsaw server to connect to the configuration? try using HTTP with 81 port to connect to the controller

Best regards,

Hello,

No, i'm using BOS Server install on windows. 

Hello,

In my case 2 pieces of Jigsaw. Same problem on both.  HTTP with port 81 did not resolve the problem.

Hello,

first connection to the new version may cause issue with HTTPS, but connecting trough 81 port and then restarting the device should resolve the HTTPS issue.

If you have this issue on windows machine, try checking status of bOS service monitor, another program might be using the same port.

Best regards.

How can I change the port? I have tried to change info onBOSService.exe.config, but the ports don't change.

Hello,

Did anyone notice the server is slower now or is it just me? For example, editing scenes (move items up/down) is now very, very slow.

Moreover, even thought the https problem is solved, when I try to edit the configuration remotely, it keeps on disconnecting and connecting making editing imposible. Downgrading makes things as they were.

Best regards

Hello Noel,

I'm getting that issue with remote access also, all stable on LAN though.

Unfortunately for me, I had to go back to previuos version.

The system became slower, there are too many errors and disconection/conection issues, even on LAN, that made this version imposible to work with for me.

I'll try fresh configuration from scratch when I have the time and let you know. But, for now, it's imposible to update any of our clients' servers due to all these issues.

Best regards,

In my opinnion problem is not related with HTTPS or HTTP connection, but rather with current configuration or file size of theme or image file. As I wrote before bOS client and web interface connects remotely without problem only bOSConfig has issues. Connection is established (as you can check with i.e.Wireshark) but configuration is not loaded.

In my case I have created backup of Jigsaw then manually deleted all themes, devices and tasks. Rebooted server and restored previuous configuration from backup and bos Config started working.

It is not ideal solution because it requires local access to LAN with server and it only resolved problem in one case. I still cannot connect remotely to second Jigsaw with bOS config. 

Can anybody acces Jigsaw Config over internet on 4.5.5?