0
Under review

LG TV control

Jürgen Jürgenson 1 year ago in bOS Configurator updated 2 months ago 19

Hey,

Is there a model list, as what models are supported? I couldn't find it. 
I have a LG 55SJ850V at home and this did not connect to it. 

Under review

Hello,

are you using Jigsaw server?

Best regards.

Noup, i'm using windows server.

Hello,

while I connect the server normally to the TV and I get the prompt for a connection and I press YES, however, it does not work then through the server to operate the TV.

Hello,

for Jigsaw server, system update is required. For windows the connection should work. 

Do you get any errors when trying to connect to the TV? @Jürgen Jürgenson? Try adding some screen shots of the current situation.

We'll look into this issue, if possible we could also require teamviewer connection so we can take a look what's going on.

Best regards.

I can check that again in few days, right now i'm away so i cant check it. But when did the search for my tv it didn't find it, so i added the ip and mac manually. But it didn't connect to it. No other errors.

Hey,

So i see that its trying to connect. Now my TV's ip is shown with the search, and when i connected to it, tv asked for pairing i pressed yes but bOS cant connect to it.

Here is a screenshot

and 

Hello,

thank you for additional information. Which LG TV model are you using? What is the current version of LG Web OS?

Best regards.

Hey,

Model is  LG 55SJ850V and it should have the latest updates on it, again i'm not at home to check the fw version of web os. I can do it later tonight maybe.

Internal updating of the TV version to the last one. See it please tonight and tell me,

Software version is 05.80.25. no new updates are shown. 

Hello,

thank you for posting, we'll look into the issue. We might require any remote access to check the problem. You should see fixes coming in next week.

Best regards,

Just letting you know that with the latest beta 4.7.11, i'm able to control my LG 55SJ850V tv, sometimes it still reconnects and gives me no ACK but turning it off or on works fine.

Is there a way to connect the on/off function with Alexa? I tried some tricks but Alexa does not even discover the test switches i did for it.

Hello,

did you try adding the TV to power controller for the on/off? When clicking Discover on your alexa app, it doesn't find any devices?

Did you enable public access?

Best regards.

Hey,

Yep ive set it up like this: 

But Alexa does not find it. Public access is working fine as do other devices that are connected to alexa.

+1

Hello,

could you maybe try making a power variable and make sure alexa finds it, then try creating a program task with the variable trigger to try and turn the tv on/off. Seems direct link doesn't work, so try this workaround.

Best regards,

Program works, but alexa still didnt want to find it, so i changed my virtual light that i had done previously to switch and linked it with the boolean value. It works now, but i dont understand why it wont find any new devices, i also tried to disable the skill.

It's really strange that i cant add any new devices to Alexa.

From the picture numbers 1-5 were all added long time ago and they all work fine. Number 3 was previously added in as virtual light - i changed it now to switch on/off the TV, it works too but it wont change its switch type to switch, it stays as a light switch as it was originally done. All other devices are not coming up with discovery. Even if i make a new virtual light switch.