0

Error changing port after upgrading to 4.4.0

Frank 3 years ago in bOS Server updated by Luis Miguel Comino Rivas 2 years ago 6

Hi.

I have used another port for HTTPS communication (8443) to bOS server

REF: http://support.comfortclick.com/forums/4-comfortclick/topics/1254-error-connecting-when-port-number-are-changed/


But when I upgraded to 4.4.0 today, it defaulted back to port 443 and I cannot change it back to 8443.

I the file: C:\Program Files (x86)\ComfortClick\bOS Server\BOSService.exe.config it still says 8443 and I have restarted the service with bOS Service Monitor, but it is still on port 443??


Are there any new routines for changing ports in v. 4.4.0?


Any ideas why it don't work?

A work-a-round is to check file Status.txt located in Server directory and do the change here and restart the service. Should do the trick. Don´t know if it is a bug or the new way to do it. Worth a try anyway :)

Hi.

The status.txt says 443, but if I change it to 8443 (after modifying security due to access denied) and restart the services it automatically goes back to 443 again ....  any other ideas?

Solution:

Editing the Settings.txt file and restart services did the trick. (and delete the cert...again...)

The Status.txt file just shows the status in the Service Monitor.

+1

Sorry, wrote the wrong file name to you. That is correct. It is the settings.txt that should be changed. Anyway, you find it by your self!

Though I don´t know if this is the right way to go or if it is a develop settings that has been released to 4.4.0 :)

Hi, I can not use port 443, since I use another device and although I follow the instructions to open another port I get the error:
Server not available Check if ports are open. (See the manual)