+1
Under review

iOS client issue ?

Bart Schellens 2 years ago in bOS Client updated 2 years ago 18

Seems after returning from holiday my iOS devices can't open my project anymore ?  The login page doesn't appear and keeps searching for the controller, both in local and remote (4G) mode.

Web page and Android client login is working perfectly local and remote ?

I tried 3 iOS devices (1 iPhone, 2 iPads) and none of them make it to the login page.

I re-imported the profiles from my account on all 3 devices but no luck.

I noticed iOS had installed during my absence an automatic update of the client app.

Anyone having similar issues ?

Best regards,

Bart

Hi.


No problems here...


I've also updated Comfortclick app on Apple Store today, and my config is working ok. both in Android and iOS.


But I'm using an old iPad 2 with iOS 9.3.5, so I can't tell you about newer iOS versions.


Best regards,

Ricardo

Hi,


No problem neither on an old iPad 2 with iOS 9.3.5 nor on 2 iPhone with iOS 10.3.3


Regards,

Btw,


After I updated the iOS app,  I'm getting almost constantly the following message before the loading:


"Alert: do you want to accept the servers public key?"


Anyone facing the same alert?

Not really.


I checked with an older iPhone on which the client app wasn't updated and that still works?

I also tried deleting the clients in BosConfig but no success...


Under review

Hello,


if you're having trouble with connecting to your controller, try removing the controller profile and adding it back again and reconnecting. The alert has been added because of the new Apple regulations. Similar pop up can be seen on android as well, simply click OK. The pop up is meant to inform you that you are connecting to a actual controller.


Regards.

Still no luck here. I deleted the entire app, re-installed from AppStore and re-imported the profile from my account (multiple times) and still no luck. All others devices (via Web, Android, old iPhone with 4.2 version) still working without problems.

I'm running iOS10.3 on the specific iPad with 4.3 client App. As a backup (it's a wall mounted iPad) I'm using a web page login on that same iPad (so there definitely is no network problem) but the App is more practical.

I'm also not getting the extra pop up that was mentioned here (neither on my Android phone) ? Maybe that's already suspicious ?


Best regards,

Bart

Hello,


I'm having a similar issue using my IPAD, the manual configurations do not allow me to edit the Iocal address to use a http conection, after i type the address it is shown like this: "https:http:myadress.com:port".


 I think that you guys are working to solve the problem pointed by Bart Schellens in a  update that was released yesterday, but now my app is just crashing when it is opened.


Any thoughts on that?


Regards.
Jefferson Santos

Hello,


why are you trying to connect using http? Why not use https or AccessID?


Your app is crashing when you open it? Or does it crash when you try to connect?


Regards.

Hi!


I'm from Brazil, and unfortunately all the ISP are terrible, not just because the high prices but also because they keep all Ports closed, preventing me from use https or even AcessID...


There are a few cases that i have mannaged to redirect the acess through the router but sadly only with the http connection...


The App crashs when i try to interact with it, touching to conect to a server, or even trying to edit a previous configuration.

Hello,


crashing error has been fixed, expect a new update shortly.


Regards.

just updated to the latest app version (4.3.2) but the app still crash immediately at startup on both my devices described above.... Any chance to revert back to 4.3.0 until the right fix comes out?

My iOS client is working again after the latest update. Thank you for resolving this.

I did have to manually configure though. Re-importing the profile didn't help.


Best regards,

Bart

After I use text to speech my iOS client it crashes (closes). I use the latest version of client running on iPad 2 - latest available iOS. Anyone experience same issue?


Regards,


Miran

Updated my iPhone to iOS 11 yesterday night. No changes, the app still crach immediately at startup on all my iOS devices (since 4.3.1)...


Regards,

@Fabien Fuster


Did you try to uninstall the app and install it again? This fixed this crash issue with all of our clients so far.


Regards.

Thanks, this worked on all devices! Don't know why I din't try it.....


Regards

This is still a problem.  I have a licensed server v4.3.6 running on Windows 10.  I can connect to it reliably with the Android Client running on a tablet and the Windows Client on 2 separate PCs.  From my iPad and my iPhone I can connect to the server using Safari to both the local address and the public address but the bOS client for iOS will not connect on my iPad or my iPhone either while on my Wireless network or using the 4G on my iPhone.


If you click on the newly imported profile from the screen entitled bOS Client the first time it will generally try to connect very briefly and then return to this screen.  Clicking again will just sit at the page with the b)S logo in the center, the name of my controller at the top and the word disconnect at the bottom


I have tried


1) Deleting and re-importing the profile on the App

2) Deleting the entry called "Scott's iphone" under user

3) Removing and re-installing the application on the iphone


My iPhone 7 and iPad Pro are both running iOS 10.3.3 (14G60).  I gt the same result on an iPad Air 2 running 11.0.2 (15A421)




I also still had those issues and also tried all these things but making a new manual profile did the trick for me, at least local, haven't tried 4G since I only use iOS at home. Android and Safari everything works ...