0

Speak Text stops working

Nathan Meinck 12 months ago in bOS Configurator updated by Ricardo Pinto | visiontech pt 12 months ago 2

The Speak Text function stops working, restarting the service monitor doesn't help, system reboot doesn't fix it. A cold reboot of the Jigsaw sometimes fixes it but not consistently.

It's been running for 6 months, and it has only just started playing up, probably for 1 month.

Any assistance would be greatly appreciated.

+1

Hey,

I think TTS is device dependent. Can you check if this problem is on other devices too? I checked my jigsaw(4.9.23) tts with Windows client and Android12 worked fine on both.

Hello,

I don't use SpeakText, but I've quickly tested out some random text, and it's working for me (Jigsaw).

You're referring to a "Service monitor", but there's no such thing on Jigsaw, neither on Configurator if you're using a Jigsaw. If you have Service Monitor on your computer, then you're also running a bOS Server on that computer, and that Service Monitor is for that local server. But it has nothing to do with the Jigsaw, so if your problem is on a Jigsaw, restarting the Service Monitor doesn't do anything.

As for the TTS, I don't use the SpeakText at all, but I've tested it out now on a Jigsaw and it worked.

Some results of my testing:

  • You need the bOS Client to be opened, (don't forget to disable battery saving options on Android) with a login on a server of your choice (in this case the one you're firing up the SpeakText function); Otherwise if you have several servers like me, and you're on the servers list without login in, the TTS doesn't play, which makes sense;

  • I've tested with the app on the background, with a login opened on my server, and it worked. But, I locked my device, and tried the SpeakText while the app was still on the background, and it didn't played. But right after unlocking the device the TTS played; So I guess it doesn't work while the device is locked / screen off;

  • The Media volume on the smartphone can't be on mute;

Also, I've noticed that when the app is running on background, the TTS sometimes takes a little time before playing.

Best rergards