0

RPC is not working

Andrzej Szymkowicz 8 months ago in bOS Server updated 8 months ago 8

Hello,

RPC is Enable, user and password i set, but curl command returns nothing:

curl --insecure -X POST -H "Content-type: application/json" -d '{"objectName":"Devices\Sonos\Speakers\Office L","valueName":"Connected"}' https://andy:andy@192.168.1.20/API/RPC/GetValue

What am I doing wrong?

bos installed on windows machine, ver. 4.6.31.

Andrzej


Hey,

I honestly never used the GetValue functions from the RPC, only SetValue. In fact I use it everyday, to activate my go to sleep scene from IFTTT as a widget.

I'll test it out tomorrow.

Best regards


Hi,

I've noticed that when using the path, for me it only works with one "\" on IFTTT service. If using other service, it only works for me with two "\", like "\\".

I used bOS to test out the communication with RPC, so I'm basically using RPC to GetValue from a local value

I also tested with curl on windows command line, and I also don't get any reply back.

curl --insecure -X POST -H "Content-type: application/json" -d '{"objectName":"Devices\\KNX\\Iluminação\\Tomada direita escritorio","valueName":"Value"}' https://username:password@192.168.1.200/API/RPC/GetValue

But if using bOS itself for testing, I can get a correct answer. Just note that you might need to use "\\" in the path.

Thanks Ricardo,

Reading is woriking wit "\\" int the path

But now I have problem with writing value:

curl --insecure -X POST -H "Content-type: application/json" -d '{"objectName":"Devices\\String","valueName":"Valu,"value":"aaa"}' https://andy:andy@192.168.1.20/API/RPC/SetValue

As the response I receive:

{"Success":false,"Message":"Odwołanie do obiektu nie zostało ustawione na wystąpienie obiektu.","Value":null}

Probably you're sending a value that's not possible... like a boolean, only accepts true or false, not aaa, or whatever...

I've create the same http devices on my bOS, with SetValue. I created two, one to send an ON command (true), and another to send a OFF command (false), and both of them are working.

As I said, I'm using IFTTT everyday, to trigger the sleep scene...

You need to double check what's wrong in your settings...

This is a text object so "aaa" is the correct value.

Anyway thanks for the response, I will double-check my configuration.

Best regards

AS

Here's my example:

Change the IP address for your server, and insert your RPC Username and Password on the Authentication.

Sometimes when messing around, like copying commands, moving, etc, can cause the commands to not to be sent. After a few minutes of messing around, I actually got some "null" values like you. I had to disable/enable the device, like to force the commands to work again. Weird...

Best regards

RPC Light control.bos