0

Amazon Alexa authorization page error

Ricardo Pinto | visiontech.pt 2 years ago updated 2 years ago 4

Hi,


After changing the port forwarding of my server for security reasons (different port forwarded to the default 443), I lost connection with Amazon Alexa skill.


So, I disabled the skill and tried to enable it again, but I'm constantly getting an error page while opening the authorization page. The authorization page doesn't open (HTTP ERROR 404).




Also, the Controllers page on my profile appear as empty. Despite this errors, I can still access to my server with the remote address...


Is there any bug with the Alexa skill authorization page?

To me it seems like you have a connection problems.

After that happens, have you tried to navigate to www.comfortclick.com? Does it open the site?


Have you tried to enable skill via your desktop computer (alexa.amazon.com)?

I don't have any connections problems. I can access the server using the apps, and I've never had problems so far.


A few days ago, I decided to change the port forwarding from (external port 443 > internal port 443) to (external port 60443 > internal port 443) for security reasons.


After that, I could still access the server remotely, by changing my remote address to https://something.etc.com:60443.


But, my Amazon Alexa stopped responding, always saying the server was not responding. So I disable the skill, to enable again to see if it would find the server on port 60443, but didn't had any luck. That's when I found my Controllers page empty, and was not able to get to the Authorization page.


Today I decided to move back the port porwarding back to 443 > 443, and I was able to enable the skill again.


So, with port forwarding from/to different port, it looks like Alexa doesn't see the server...


Is there any user who changed the default 443 port on the server config, and is able to use Amazon Alexa skill? Or the skill only sees the server if it's listening on default 443 for https?


Regards

Did you changed the port under public address for your controller?

https://www.comfortclick.com/Account/Controllers

The url under Public Address must match your https://address:port/

Never had the chance... After changing the port forwarding, the controllers list showed as empty, so I couldn't edit the public address. Also the authorization page was broken all the time. That's why I rolled back to 443. 

Will try it again...