0

Ezviz H8 pro RTSP integration

Jürgen Jürgenson 7 months ago updated 7 months ago 6

Hey,

Has anyone played with Ezviz devices? I have H8 Pro for testing. I would like to use it in bOS too. I activated the RTSP stream on it but cant get any stream to play in bOS. It doesn't have ONVIF sadly but it has PTZ support. It's also supported by amazon and google home. I think it would be possible to use it with Hikvision NVR as port 8000 should also work on it.


RTSP link should be on it: rtsp://%u:%p@%ip:554/1 or /2 for lower video quality.

Any plans to integrate a driver for it @CC support? 

This should be the correct link... Havent tested it yet, but got this info from ezviz support.
rtsp://admin:verification code@device ip/h264/ch1/main/av_stream

(Note: verification code is the 6 capital letters code you can find on the device label; device IP is the IP address of your camera)

Still no bueno I cant get it to stream on bOS. That last link works on VLC - but not with the 6 capital letters, but with the admins password, strange.

Hello,

As far as I know, EZVIZ is a subsidiary of Hikvision.

Even though it may not be necessarily the same basis, have you tried with other url's related to Hikvision devices?


Kind of like:


rtsp://user:password@device_ip/Streaming/channels/101


You may also test the jpg and mjpeg url's.


http://%u:%p@%ip/ISAPI/Streaming/channels/101/picture


http://%u:%p@%ip/ISAPI/Streaming/channels/102/httpPreview


Best regards

I've tried many different links - so far none have worked in bOS. Seems like H8 pro version is watered down so it does not support much. 

Yeah, it looks like Ezviz is probably trying to disable features, probably trying to force the users not to use third-party apps or devices.

There a a large number of posts on the internet, some say that they successfully re-established the RTSP after loosing it after a firmware update, etc, but you have to test it out and see if it.

Ezviz Disables RTPS for its IP Cameras, Here is the fix! | IP Cam Talk

Best regards

RTSP is active - the port 554 is working on it and seen on lan port scan. RTSP works with VLC on lan just fine. But they have removed OnVIF and http features. So the image preview links dont work on it. RTSP doesnt work on bOS either no idea why yet...