+1

Panel Locked Pin

Pavlos Laskas 1 month ago updated by Ricardo Pinto 1 month ago 11

Hello,

I used a pin code to lock access to a theme panel, but when I press the X at the upper right corner I still have access to the panel.

All version are the latest, I tried it with Android and Windows Client. I also tried it in a different server. The result is the same

Hello,


I can also confirm that issue. Never noticed, because I usually don't use any pin codes.


But yes, the pin code is currently bypassed clicking on the X of the code window.


ComfortClick team, please have a look at it.


Pavlos, please open a support ticket so it can be registered in case of the team misses this post.

Best regards

+1

Hey,

I tested it on my servers and it still worked. Try to reload the server and see if the PIN code is actually there. 

Hey Jürgen,

Do you use Windows based servers?

I can confirm that on Jigsaw you can bypass the pin code by closing the pin code window as stated by Pavlos. Even after a reload. Needless to say, that we're referring about the pin code defined on the main panel, and not the confirmation dialog pins (these are working).

Tested on Jigsaw, running 4.9.17 version.

Please confirm if you're using Windows machine, so that the team can focus on the correct OS.


Best regards

+1

Yes i tested it on windows servers.

+1

https://drive.google.com/file/d/1UUd7sT2dPcI4dIltI2fWUtmvWaDnm25J/view?usp=sharing Made a short video, tested on windows client and server. I have put control panels under a PIN so maybe im doing something different. 

There are two types of "pins". Panel protection pin, where the pin is set on the main theme page, under "Unlock PIN" / "Lock timeout", and there's another kind of pin that you are using, and me also for scenes etc, which is the "Show Confirmation" dialog, where you can set a different pin for each control.

In this case, Pavlos was referring about the main pin set on the theme, and in fact it's not working / is bypassable.

On the main theme, you have a standard "1234" pin. If you set a panel to be "Locked" under "Security", it's expected to input the main theme pin code. But if we click on the X to close the dialog, we can access the panel which was supposed to be protected.

I will record a small video.

I've set the panel protection PIN to 1234, as default on the "Unlock PIN" option of the main theme page, and set the "Geral" panel to be "Locked: true".

When I click the "Geral" panel, it's asking for the protection pin. But if I click on the top X, it closes the dialog and I can see the panel which was supposed to be protected.

https://drive.google.com/file/d/1aMzoJjMWRpxmLYRz45qWVZFKemoyNIg_/view?usp=share_link


Can you please test this on your Windows machine?


Thanks

+1

Can confirm its broken on jigsaw and windows. But works on windows for me if only the control panel is locked not theme panels. With themes it don't work anymore. Tested on 3 server that are on 4.9.17. Jigsaw is on 4.9.18a.

Thanks mate.

Confirmation dialog pins work for me, I use them daily.

As for the theme panel pin, I usually never use them, but I know that they worked previously, so something is broken somewhere.

Thanks 

+1

I just tried it in a Windows Server(latest version) and the behavior is the same: You can still bypass the pin code to access a panel.

I've created a brand new main theme, to be sure that the problem is not coming from my daily theme, and in fact it happens the same, the pin code window protection can be bypassed by closing the main X on the window.


Don't forget to open a ticket to be reported, so that the ComfortClick team can have a look at the problem.