0

Modbus RTU fail

Łukasz Klinger 4 months ago updated 3 months ago 5

good morning, since the installation on the beta version grinder, there are repeated interruptions in the operation of Modbus RTU in the application there is a connection, but the controllers stop interrogating the devices, it is not enough to pull the controller from the USB socket because it has no effect, but without turning it off, turn off the connection and turn on and suddenly call back .

+1

Hey,

What is the error handling set to? If its on reconnect try write to log instead. I've also noticed that if its on reconnect it wont actually reconnect fully but it will just stop asking for updates. If its on write to log then it still receives updates even if there is some no responses. 
For one of my projects with reconnect option - it stayed connected for about ~8-10hours then it just wouldnt update even if it was connected - after modbus driver disable/enable it starts to update again.

ponowne połączenie w przypadku braku odpowiedzi. ale to nie działa i często mam problem że kilka godzin przychodzi i przestaje odpowiadać a po resecie modbusa wszystko działa dobrze

Good morning, I have a problem with the modbus RTU usb stick at the customer's place, the point is that the stick has a connection to BoS, but from time to time the end device, e.g. the energy meter, stops being polled by CC, i.e. there is no transmission and BoS does not see it and does not reset the connection, which results in the lack of readings, it is helpful to manually switch the connection from TRUE to FOLSE and back to TRUE, the Wotschdog itself should act on the lack of readings, not the lack of a device, or at least in the program it should be possible to force the connection off and no such option.

I am asking for a quick intervention because by purchasing 4 USB Modbus RTU devices connected to the GRINDER, the customer has only problems.

I would like to add that this is not a problem on the side of the end devices because they worked stably for 2 years under a different system without a problem and the fault is on the BoS side.

Additionally, I will mention that BoS does not report any errors in the logs

Dzień dobry cały czas u klienta mam problem z usb stick modbus RTU chodzi o to że pastykla ma połączenie z BoS ale co jakiś czas urządzenie końcowe np licznik energii przestaje być odpytywane przez CC czyli brakuje transmisji a BoS nie widzi tego i nie resetuje połączenia co skutkuje brakiem odczytów, pomaga ręczne przestawienie połączenia z TRUE na FOLSE i spowrotem na TRUE sam Wotschdog powinien dziąłać na brak odczytów a nie brak urządzenia lub przynajmniej w programie powinna być możliwość wymuszenia wyłacznia połaczenia a takiej opcji brak.
Proszę o szybką interewencję ponieważ zakupując 4 urządznia USB Modbus RTU podłączone do GRINDER klient ma same problemy.
Dodam, że to nie problem po stronie urządzeń końcowych gdyż te pracowały stabilnie 2 lata pod innym systemem bez problemu i wina stoi po stronie BoS.
Dodatkowo wspomnę, że BoS nie zgłasza żadnych błędów w logach

Try to reinstall the windows drivers for the usb modbus dongle. This could help in some cases.

I've already done it and the problem is back, I don't know why the BoS team doesn't want to make functionality from the program so that the connection can be turned off and on. For example, such an automatic restart every 24 hours