+1

Alexa does not discover bOS devices

Eduardo Rosa 2 years ago in bOS Configurator updated 2 years ago 7

Please, Could you help me? I'm Eduardo from Brazil. I'm trying to integrate Alexa with bOS at my customer. I did all the configuration in Alexa app and bOS, but Alexa does not discover devices. I tried to do in another server in another location and the problem is the same! The second server that I have tested worked before the version 4.4.4 and now no more!!!

Regards,

Eduardo Rosa

Try removing the skill and re-adding it. And recheck if they are still on a same network. I had similar problem when i changed my router. Here is a good how to https://www.comfortclick.com/Alexa

Hi Jürgen, thank you for your help. I have done it several times and Alexa is on the same network of the bOS server. Alexa still does not discover the devices.

Hi,

So I assume that you have port 443 correctly forwarded right? Can you access bOS from outside network?

When creating the Alexa appliances, you must not forget to name the appliances.

When you create a new appliance, you give a name to the node, let's say "Living room light", so the node is called Living room light. But inside the node Settings, you must NOT leave the Name empty, otherwise this can be the cause of Alexa not finding the devices.

Can you check that?


Best regards,

Ricardo


Hi,

Yes, I can access bOS remotely outside network and all created endpoints are named.


IP Address (bOS - server): 192.168.0.22 (reserved on the router)

IP Address (Alexa): 192.168.0.40

port 443 forwarded to 192.168.0.22 on the router.

Alexa account is linked with Comfortclick account.

+1

Hi,

Problem solved. The Local Internet Provider blocked port 443. So, I changed external port to another on the router and update it on the bOS server register. Now, Alexa discover all devices.

Thanks,

Eduardo Rosa

Hi,

I'm glad that you worked it out.

Although it doesn't make sense, as you told me that you could access remotely by port 443...

But it's working now, so that's great.

Best regards

Hi,

In the router there were 2 configurations being one redirecting the external port 443 to the internal 443 and the other 8443 to the 443. I remotely accessed the bOS by DDNS through the external port 8443, which had been configured manually in the bOS Client. But in the registry of the server (in the Comfortclick's account) it was 443. So I replaced it with 8443.

Best regards

Eduardo Rosa